]> code.ossystems Code Review - openembedded-core.git/commitdiff
libproxy: Fix for CVE-2012-4504
authoryanjun.zhu <yanjun.zhu@windriver.com>
Fri, 30 Nov 2012 11:08:56 +0000 (19:08 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Dec 2012 15:21:01 +0000 (15:21 +0000)
Reference:https://code.google.com/p/libproxy/source/detail?r=853

Stack-based buffer overflow in the url::get_pac function in url.cpp
in libproxy 0.4.x before 0.4.9 allows remote servers to have an
unspecified impact via a large proxy.pac file.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-4504

[YOCTO #3487]

Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libproxy/libproxy/libproxy-0.4.7-CVE-2012-4504.patch [new file with mode: 0644]
meta/recipes-support/libproxy/libproxy_0.4.7.bb

diff --git a/meta/recipes-support/libproxy/libproxy/libproxy-0.4.7-CVE-2012-4504.patch b/meta/recipes-support/libproxy/libproxy/libproxy-0.4.7-CVE-2012-4504.patch
new file mode 100644 (file)
index 0000000..7f2d93a
--- /dev/null
@@ -0,0 +1,29 @@
+Upstream-Status: Backport
+
+libproxy - CVE-2012-4504:
+
+Reference:https://code.google.com/p/libproxy/source/detail?r=853
+
+Stack-based buffer overflow in the url::get_pac function in url.cpp
+in libproxy 0.4.x before 0.4.9 allows remote servers to have an
+unspecified impact via a large proxy.pac file.
+
+http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-4504
+
+Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com> 
+
+diff -urpN a/libproxy/url.cpp b/libproxy/url.cpp
+--- a/libproxy/url.cpp 2012-11-26 10:08:47.000000000 +0800
++++ b/libproxy/url.cpp 2012-11-26 10:05:54.000000000 +0800
+@@ -472,9 +472,10 @@ char* url::get_pac() {
+                               // Add this chunk to our content length,
+                               // ensuring that we aren't over our max size
+                               content_length += chunk_length;
+-                              if (content_length >= PAC_MAX_SIZE) break;
+                       }
++                      if (content_length >= PAC_MAX_SIZE) break;
++
+                       while (recvd != content_length) {
+                               int r = recv(sock, buffer + recvd, content_length - recvd, 0);
+                               if (r < 0) break;
index c6a733a1df2cf762d7ed6bbc7338baa9f5c6b60a..510c6b7c4ea3afd709e8ce8319083875fdd49132 100644 (file)
@@ -13,6 +13,7 @@ PR = "r5"
 SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz \
            file://g++-namepace.patch \
            file://libproxy_fix_for_gcc4.7.patch \
+           file://libproxy-0.4.7-CVE-2012-4504.patch \
           "
 
 SRC_URI[md5sum] = "509e03a488a61cd62bfbaf3ab6a2a7a5"