]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: add the latest version 3.1.4
authorDexuan Cui <dexuan.cui@intel.com>
Tue, 31 Aug 2010 14:19:37 +0000 (22:19 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 08:50:47 +0000 (09:50 +0100)
The recipe is borrowed from OE, with the following changes:
- upgrade the version from 2.5 to 3.1.4
- simplify DESCRIPTION
- add HOMEPAGE, BUGTRACKER, LICENSE and LIC_FILES_CHKSUM, PR
- remove INHIBIT_AUTO_STAGE
- fixing coding style issue: 4 SPACES --> 1 TAB

mdadm: move to recipes-extended

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/recipes-extended/mdadm/mdadm_3.1.4.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/mdadm/mdadm_3.1.4.bb b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
new file mode 100644 (file)
index 0000000..b28e96b
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = " A tool for managing Soft RAID under Linux"
+HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
+BUGTRACKER = "n/a"
+
+#A few files are GPLv2+ while most files are GPLv2.
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+                    file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
+                    file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
+
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2"
+
+CFLAGS += "-fno-strict-aliasing"
+
+inherit autotools
+
+do_compile() {
+       export CROSS_COMPILE="${TARGET_PREFIX}"
+       oe_runmake
+}
+
+do_install() {
+       export STRIP=""
+       autotools_do_install
+}
+