]> code.ossystems Code Review - openembedded-core.git/commitdiff
diffutils: added 2.8.1 for SDK (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 27 Apr 2007 13:21:00 +0000 (13:21 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 27 Apr 2007 13:21:00 +0000 (13:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1568 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/diffutils/diffutils_2.8.1.bb [new file with mode: 0644]

diff --git a/meta/packages/diffutils/diffutils_2.8.1.bb b/meta/packages/diffutils/diffutils_2.8.1.bb
new file mode 100644 (file)
index 0000000..a0a7b7d
--- /dev/null
@@ -0,0 +1,25 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
+sdiff, and cmp utilities. These programs are usually \
+used for creating patch files."
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality.  regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_linux-uclibc = "--without-included-regex"
+
+do_install_append () {
+        mv ${D}${bindir}/diff ${D}${bindir}/diff.${PN}
+}
+
+ALTERNATIVE_NAME = "diff"
+ALTERNATIVE_PATH = "diff.${PN}"
+ALTERNATIVE_PRIORITY = "100"