]> code.ossystems Code Review - openembedded-core.git/commitdiff
libx11-trim: fix location on keysymdef.h
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 22 Sep 2008 14:46:13 +0000 (14:46 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 22 Sep 2008 14:46:13 +0000 (14:46 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5214 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xorg-lib/libx11-trim/include_fix.patch [new file with mode: 0644]
meta/packages/xorg-lib/libx11-trim_1.1.5.bb

diff --git a/meta/packages/xorg-lib/libx11-trim/include_fix.patch b/meta/packages/xorg-lib/libx11-trim/include_fix.patch
new file mode 100644 (file)
index 0000000..99ed571
--- /dev/null
@@ -0,0 +1,23 @@
+---
+ configure.ac |    6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- libX11-1.1.5.orig/configure.ac
++++ libX11-1.1.5/configure.ac
+@@ -218,13 +218,13 @@ AC_SUBST(XDMCP_LIBS)
+ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL, 1, [poll() function is available])], )
+ #
+ # Find keysymdef.h
+ #
+-AC_MSG_CHECKING([keysymdef.h])
+-dir=`pkg-config --variable=includedir xproto`
+-KEYSYMDEF="$dir/X11/keysymdef.h"
++AC_ARG_WITH(keysymdef,
++      AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
++      KEYSYMDEF=$withval, KEYSYMDEF="")
+ if test -f "$KEYSYMDEF"; then
+         AC_MSG_RESULT([$KEYSYMDEF])
+ else
+       AC_MSG_ERROR([Cannot find keysymdef.h])
+ fi
index 659b7ba5b07e9455eae905e1f01cfa8402ba3ec5..77f0d28341198cc38b7a5a664604367eb34a7d61 100644 (file)
@@ -9,11 +9,14 @@ DEPENDS += "libxcb xproto xextproto xtrans libxau"
 PROVIDES = "virtual/libx11"
 
 PE = "1"
-PR = "r0"
+PR = "r1"
 
 XORG_PN = "libX11"
 LEAD_SONAME = "libX11.so"
 
+SRC_URI += "file://include_fix.patch;patch=1"
+
+EXTRA_OECONF += "--with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
 #EXTRA_OECONF += "--disable-xlocale --disable-xcms --with-xcb"
 EXTRA_OECONF += "--disable-xcms --with-xcb"