]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-2.0: Fix hardcoded paths in checksums
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Jan 2020 17:56:16 +0000 (17:56 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 11 Jan 2020 15:19:21 +0000 (15:19 +0000)
The expansion by this function, recently added by the meson site handling code
was causing hardcoded paths to become embedded in the tash hashes. Avoid this
(and hence avoid eSDK failures which exposed this).

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb

index 953fba501a748e97d8c516b2b36ea731ecad5495..5e71c81cca19f8536d831720d264ab70f37806d1 100644 (file)
@@ -29,6 +29,7 @@ def find_meson_cross_files(d):
     if bb.data.inherits_class('native', d):
         return ""
 
+    corebase = d.getVar("COREBASE")
     import collections
     sitedata = siteinfo_data(d)
     # filename -> found
@@ -36,7 +37,7 @@ def find_meson_cross_files(d):
     for path in d.getVar("FILESPATH").split(":"):
         for element in sitedata:
             filename = os.path.join(path, "meson.cross.d", element)
-            files[filename] = os.path.exists(filename)
+            files[filename.replace(corebase, "${COREBASE}")] = os.path.exists(filename)
 
     items = ["--cross-file=" + k for k,v in files.items() if v]
     d.appendVar("EXTRA_OEMESON", " " + " ".join(items))