]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm 5.4.9: DEPENDS on bison-native
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 18 Sep 2012 11:26:17 +0000 (19:26 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 21 Sep 2012 05:21:14 +0000 (22:21 -0700)
The rpm should depend on bison-native, otherwise errors when "bitbake
rpm-native" in a fresh build:

| make[4]: Entering directory `/path/to/rpm-native-5.4.9-r46/rpm-5.4.9/syck/lib'
| bison -d -t -v -p syck -o gram.c gram.y
| make[4]: bison: Command not found

Basically, both the rpm-native and rpm should depend on bison-native,
but don't need depend on bison, but it seems that it isn't necessary
to add another depend line:

DEPENDS_virtclass-native = "libpcre-native ... bison-native"

So just add it to the DEPENDS.

[YOCTO #3123]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index e276cc341bdd60d16dd84be25304cb207b56b510..3b005704e722bf11f1f3203b6adc083b883b6f89 100644 (file)
@@ -42,8 +42,8 @@ HOMEPAGE = "http://rpm5.org/"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
-DEPENDS = "libpcre attr acl popt ossp-uuid file"
-PR = "r46"
+DEPENDS = "libpcre attr acl popt ossp-uuid file bison-native"
+PR = "r47"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...