]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: Use SYSROOT_DIRS_BLACKLIST to exclude dirs from the sysroot
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Thu, 12 May 2016 08:38:02 +0000 (10:38 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 May 2016 12:40:50 +0000 (13:40 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libtool/libtool_2.4.6.bb

index 3851ec7f8389ef24f19276a0263f6b9ed3c9a6d2..8858f6eef8204db72d09fc8ebef7be409070b690 100644 (file)
@@ -5,7 +5,11 @@ RDEPENDS_${PN} += "bash"
 #
 # We want the results of libtool-cross preserved - don't stage anything ourselves.
 #
-SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
+SYSROOT_DIRS_BLACKLIST += " \
+    ${bindir} \
+    ${datadir}/aclocal \
+    ${datadir}/libtool/build-aux \
+"
 
 do_install_append () {
         sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \
@@ -18,10 +22,3 @@ do_install_append () {
             -e 's@^\(postdep_objects="\).*@\1"@' \
             -i ${D}${bindir}/libtool
 }
-
-libtool_sysroot_preprocess () {
-       rm -rf ${SYSROOT_DESTDIR}${bindir}/*
-       rm -rf ${SYSROOT_DESTDIR}${datadir}/aclocal/*
-       rm -rf ${SYSROOT_DESTDIR}${datadir}/libtool/build-aux/*
-}
-