]> code.ossystems Code Review - openembedded-core.git/commitdiff
icecc-create-env: rename to -native
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Wed, 21 Sep 2011 18:39:48 +0000 (22:39 +0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 04:09:02 +0000 (05:09 +0100)
icecc-create-env(-native) is a native package. But if it doesn't have
the -native suffix, some dependency tracking stuff in oe-core (in
nativesdk.bbclass) get's crazy about it, trying to generate dependencies
to icecc-create-env-native packages. To fix that simply add -native
suffix to this package.

Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/icecc.bbclass
meta/recipes-devtools/icecc-create-env/icecc-create-env-native/icecc-lto-update.patch [moved from meta/recipes-devtools/icecc-create-env/icecc-create-env/icecc-lto-update.patch with 96% similarity]
meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb [moved from meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb with 100% similarity]

index e20666b7434089f869f1f9c8d9e6dfa59e61df3d..710d7982ca48f329a608aff346927c9fb4de6b87 100644 (file)
@@ -33,7 +33,7 @@ def icecc_dep_prepend(d):
     # we need that built is the responsibility of the patch function / class, not
     # the application.
     if not bb.data.getVar('INHIBIT_DEFAULT_DEPS', d):
-        return "icecc-create-env"
+        return "icecc-create-env-native"
     return ""
 
 DEPENDS_prepend += "${@icecc_dep_prepend(d)} "
similarity index 96%
rename from meta/recipes-devtools/icecc-create-env/icecc-create-env/icecc-lto-update.patch
rename to meta/recipes-devtools/icecc-create-env/icecc-create-env-native/icecc-lto-update.patch
index b396261d69c0c680b94dd966496d25d335d9762d..a7af2e3a98b67c2dcae8b1e1e78e171ae1657f7c 100644 (file)
@@ -1,7 +1,7 @@
 --- a/icecc-create-env 2006-12-14 09:50:46.000000000 +0300
 +++ b/icecc-create-env 2011-08-31 17:52:45.000000000 +0400
 @@ -27,9 +27,6 @@
-   # readlink is not portable enough. 
+   # readlink is not portable enough.
    path=`ls -H $path`
    toadd="$name=$path"
 -  if test "$name" = "$path"; then
@@ -13,7 +13,7 @@
 @@ -117,6 +114,14 @@
    add_file "$specfile"
  fi
+
 +ltofile=`$added_gcc -print-prog-name=lto1`
 +pluginfile="${ltofile%lto1}liblto_plugin.so"
 +if test -r "$pluginfile"
 +
  tempdir=`mktemp -d /tmp/iceccenvXXXXXX`
  new_target_files=
- for i in $target_files; do 
+ for i in $target_files; do
 @@ -140,49 +147,44 @@
  done
+
  #sort the files
 - target_files=`for i in $new_target_files; do echo $i; done | sort`
 +target_files=`for i in $new_target_files; do echo $i; done | sort`
+
  #test if an archive name was supplied
  #if not use the md5 of all files as the archive name
  if test -z "$archive_name"; then
@@ -49,7 +49,7 @@
 +      break
 +    fi
 +  done
+
 -#calculate md5 and use it as the archive name
 -archive_name=`for i in $target_files; do $md5sum $tempdir/$i; done | sed -e 's/ .*$//' | $md5sum | sed -e 's/ .*$//'` || {
 -  if test -z "$silent"; then
@@ -64,7 +64,7 @@
 +  mydir=`pwd`
 +else
 +  mydir="`dirname "$archive_name"`"
-+ 
++
 +  #check if we have a full path or only a filename
 +  if test "$mydir" = "." ; then
 +    mydir=`pwd`
 -}
 -
  fi
+
  if test -z "$silent"; then
 -echo "creating $archive_name.tar.gz"
 +echo "creating $archive_name"
  fi
+
 -if test -z "$archive_name"; then
 - mydir=`pwd`
 -else
 -# mydir=dirname ${archive_name}
 -  mydir=${archive_name%/*}
-- 
+-
 -#check if we have a full path or only a filename
 - if test -z "$mydir"; then
 -  mydir=`pwd`