]> code.ossystems Code Review - openembedded-core.git/commitdiff
classes/conf: Update to handle gcc-runtime
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 29 Mar 2010 21:28:49 +0000 (22:28 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 29 Mar 2010 21:28:49 +0000 (22:28 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/classes/base.bbclass
meta/classes/insane.bbclass
meta/classes/nativesdk.bbclass
meta/conf/distro/include/poky-default.inc

index 51a514570bb40c41cd691ad5a7c1bb1da06f9442..4e8ae127a7322def74c5ca0f3decc34177d0d203 100644 (file)
@@ -28,7 +28,7 @@ def base_dep_prepend(d):
        if not bb.data.getVar('INHIBIT_DEFAULT_DEPS', d):
                if (bb.data.getVar('HOST_SYS', d, 1) !=
                    bb.data.getVar('BUILD_SYS', d, 1)):
-                       deps += " virtual/${TARGET_PREFIX}gcc virtual/libc "
+                       deps += " virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}compilerlibs virtual/libc "
        return deps
 
 
index 913d88de64827bc4648c5477c51464e4a0816e31..d8cc6792839c93cb20479530de9e8f5fc007624d 100644 (file)
@@ -500,7 +500,7 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
         if "configure.in" in files:
             configs.append(os.path.join(root, "configure.in"))
 
-    if "gettext" not in bb.data.getVar('P', d, True):
+    if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True):
        if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
           gt = "gettext-native"
        elif bb.data.inherits_class('cross-canadian', d):
index 75f5790121266eedf3099836cf185a45fd03f698..95ffc064af83762be73982766cc2ad197f9823a1 100644 (file)
@@ -62,7 +62,7 @@ python __anonymous () {
     for dep in deps:
         if dep.endswith("-native") or dep.endswith("-cross"):
             newdeps.append(dep)
-        elif dep.endswith("-gcc-intermediate") or dep.endswith("-gcc-initial") or dep.endswith("-gcc"):
+        elif dep.endswith("-gcc-intermediate") or dep.endswith("-gcc-initial") or dep.endswith("-gcc") or dep.endswith("-g++"):
             newdeps.append(dep + "-crosssdk")
         elif not dep.endswith("-nativesdk"):
             newdeps.append(dep + "-nativesdk")
index f5882a278cc5b1d4aefd51ecc2e5ce4daf6c77f1..e0d42c682314a5106429bd72c60a1dee6d933bad 100644 (file)
@@ -10,6 +10,7 @@ PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-initial = "gcc-cross-initial"
 PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-intermediate = "gcc-cross-intermediate"
 PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc = "gcc-cross"
 PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}g++ = "gcc-cross"
+PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}compilerlibs = "gcc-runtime"
 
 GCCVERSION ?= "4.3.3"
 BINUVERSION ?= "2.20"