]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: add init script depends
authorRoss Burton <ross@openedhand.com>
Thu, 3 Jul 2008 15:27:51 +0000 (15:27 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 3 Jul 2008 15:27:51 +0000 (15:27 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4808 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/busybox/busybox_1.9.1.bb
meta/packages/busybox/files/hwclock.sh
meta/packages/busybox/files/syslog

index cec4af8d59306b573f0a9c8d1f3131c81bc90a3b..acef71827612ce5541e209f96a369002116849e5 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r4"
+PR = "r6"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
            http://busybox.net/downloads/fixes-1.9.1/busybox-1.9.1-lineedit.patch;patch=1 \
index 5acfb9fb241b2296771905bfea4bcd439e7919d2..2e50425ba835a3c115a148d24a6a1073b2fc599e 100644 (file)
@@ -1,6 +1,14 @@
 #!/bin/sh
-# hwclock.sh Set system clock to hardware clock, according to the UTC
-#               setting in /etc/default/rcS (see also rcS(5)).
+### BEGIN INIT INFO
+# Provides:          hwclock
+# Required-Start:    
+# Required-Stop:     $local_fs
+# Default-Start:     S
+# Default-Stop:      0 6
+# Short-Description: Set system clock
+# Description:       Set system clock to hardware clock, according to the UTC
+#                    setting in /etc/default/rcS (see also rcS(5)).
+### END INIT INFO
 #
 # WARNING:      If your hardware clock is not in UTC/GMT, this script
 #               must know the local time zone. This information is
index a999565e8444343af5c41613df025572acd9e4bf..544524b26c5640792beaea083fe1d0bdd5979d59 100644 (file)
@@ -1,8 +1,13 @@
 #! /bin/sh
-#
-# syslog       init.d script for busybox syslogd/klogd
-#              Written by Robert Griebl <sandman@handhelds.org>
-#               Configuration file added by <bruno.randolf@4g-systems.biz>
+### BEGIN INIT INFO
+# Provides:             sysklogd
+# Required-Start:       $remote_fs $time
+# Required-Stop:        $remote_fs $time
+# Default-Start:        2 3 4 5
+# Default-Stop:         0 1 6
+# Short-Description:    System logger
+### END INIT INFO
+
 set -e
 
 if [ -f /etc/syslog.conf ]; then