]> code.ossystems Code Review - openembedded-core.git/commitdiff
automake: simplify perl location forcing logic
authorRoss Burton <ross.burton@intel.com>
Fri, 15 May 2015 16:42:09 +0000 (17:42 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 May 2015 16:58:40 +0000 (17:58 +0100)
Instead of letting configure find the host's perl and then use a complicated sed
to replace it at install time, simply pre-seed the configure logic with the path
we want to use.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/automake/automake_1.15.bb

index d5b6e9eba4f83ad655fb902e74d8797f2b8250f5..c33dc22679bca6fbe9c482bafd61ff442161e50f 100644 (file)
@@ -25,18 +25,10 @@ SRC_URI += " file://python-libdir.patch \
 SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
 SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"
 
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL=${USRBINPATH}/perl"
+
 do_install_append () {
     install -d ${D}${datadir}
-
-    # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
-    # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
-    for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
-        if [ -f ${D}${bindir}/$i ]; then
-            sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
-            -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
-            ${D}${bindir}/$i
-        fi
-    done
 }
 
 BBCLASSEXTEND = "native nativesdk"