]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsbsetup: use ${bindir} instead of /usr/bin for packaging
authorJavier Martinez Canillas <javier@dowhile0.org>
Sun, 5 Aug 2012 19:48:31 +0000 (21:48 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Aug 2012 13:18:23 +0000 (14:18 +0100)
It is considered good practice to use the build system provided
variables instead of directly specify hardcoded paths.

Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsbsetup_1.0.bb

index 9172ee3b05edc3c4c603e69359d552612fe35b77..2792d51f23401a38d01dd4077bfb288709c48e03 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "auto-setup environment for lsb test"
 SECTION = "console/utils"
 LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
 
 LIC_FILES_CHKSUM = "file://LSB_Setup.sh;beginline=3;endline=16;md5=97451c7c0786ce5bbe9ac58042945583"
 
@@ -11,9 +11,9 @@ S = "${WORKDIR}"
 
 do_install() {
     # Only install file if it has a contents
-    install -d ${D}/usr/bin
+    install -d ${D}${bindir}
     install -d ${D}/${sysconfdir}
-    install -m 0755 ${S}/LSB_Setup.sh ${D}/usr/bin
+    install -m 0755 ${S}/LSB_Setup.sh ${D}${bindir}
     install -d  ${D}/${libdir}/lsb
     ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
     ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd