]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-dri-git: Handle cross compiling of the glsl utils
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 5 Feb 2010 14:08:37 +0000 (14:08 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 5 Feb 2010 14:08:37 +0000 (14:08 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/mesa/mesa-dri_git.bb

index 867bdce0b73086c6225cbecc1a09fa37d7ea7a3d..35cb7fa6ffc4f81bd64fc17401611ac78b77084b 100644 (file)
@@ -11,8 +11,8 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS}"
 
-PV = "7.5+git${SRCPV}"
-PR = "r14"
+PV = "7.7+git${SRCPV}"
+PR = "r0"
 
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
@@ -35,6 +35,14 @@ do_configure_prepend () {
     touch ${S}/src/mesa/x86/matypes.h
 }
 
+do_compile () {
+       oe_runmake clean
+       oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
+       mv ${S}/src/glsl/apps/compile ${S}/host_compile
+       oe_runmake clean
+       oe_runmake GLSL_CL="${S}/host_compile"
+}
+
 do_install_append () {
     install -d ${D}/usr/bin
     install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/