]> code.ossystems Code Review - openembedded-core.git/commitdiff
iproute2: fix an issues with DATETIME
authorNitin A Kamble <nitin.a.kamble@intel.com>
Thu, 27 May 2010 19:15:40 +0000 (12:15 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 2 Jun 2010 13:06:02 +0000 (14:06 +0100)
The DATE variable in this bb files was distrubing the DATETIME variable
used by the distro_check task.
Renamed the DATE variable to SRCDATE

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/packages/iproute2/iproute2.inc
meta/packages/iproute2/iproute2_2.6.18.bb

index 006b27b60f686ebe1b581f8331edf34c5bd9415e..0d7b11028a2cd5f55dc1bf34735910c658584e35 100644 (file)
@@ -3,10 +3,10 @@ SECTION = "base"
 LICENSE = "GPL"
 DEPENDS = "flex-native bison-native"
 
-# Set DATE in the .bb file
-SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
+# Set SRCDATE in the .bb file
+SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${SRCDATE}.tar.gz"
 
-S = "${WORKDIR}/${P}-${DATE}"
+S = "${WORKDIR}/${P}-${SRCDATE}"
 
 EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin"
 
index 72eb39d69dde37bedfdf1737fcaaa7c463951cb6..0fc0b8f98c1def0c8d1e065fcaabd28ccf532b27 100644 (file)
@@ -5,4 +5,4 @@ require iproute2.inc
 SRC_URI += "file://iproute2-2.6.15_no_strip.diff;patch=1;pnum=0 \
             file://new-flex-fix.patch;patch=1"
 
-DATE = "061002"
+SRCDATE = "061002"