]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter: Add missing patch
authorRichard Purdie <richard@openedhand.com>
Thu, 26 Jun 2008 15:50:35 +0000 (15:50 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 26 Jun 2008 15:50:35 +0000 (15:50 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4735 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/clutter/clutter/enable-tests-r2990.patch [new file with mode: 0644]

diff --git a/meta/packages/clutter/clutter/enable-tests-r2990.patch b/meta/packages/clutter/clutter/enable-tests-r2990.patch
new file mode 100644 (file)
index 0000000..4f449b1
--- /dev/null
@@ -0,0 +1,50 @@
+---
+ tests/Makefile.am   |    7 ++++++-
+ tests/test-actors.c |    2 +-
+ tests/test-text.c   |    2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am     2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/Makefile.am  2008-06-26 16:46:50.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+                   test-actors test-behave test-text test-entry test-project \
+                 test-perspective test-rotate test-depth \
+                 test-threads test-timeline test-timeline-dup-frames \
+@@ -17,8 +17,8 @@
+                 test-invariants
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
+-noinst_PROGRAMS += test-devices
++bin_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-devices
+ endif
+ INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
+@@ -73,4 +73,9 @@
+ test_invariants_SOURCES           = test-invariants.c
+ test_devices_SOURCES              = test-devices.c
++test_textdir           = $(pkgdatadir)
++test_text_DATA         = test-text.c
++test_actorsdir         = $(pkgdatadir)
++test_actors_DATA       = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c   2008-06-26 16:46:26.000000000 +0100
++++ clutter/tests/test-actors.c        2008-06-26 16:46:31.000000000 +0100
+@@ -195,7 +195,7 @@
+       /* Create a texture from file, then clone in to same resources */
+       if (i == 0)
+       {
+-        if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++        if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+                                                           &error)) == NULL)
+           {
+             g_error ("image load failed: %s", error->message);