]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: Add PACKAGE_WRITE_DEPS for postinst
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 17:01:10 +0000 (17:01 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 22:51:06 +0000 (22:51 +0000)
The postinstall needs systemd-systemctl-native, mark the dependency

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initscripts/initscripts_1.0.bb

index 8f110b0050f2059764d5f28bdc38264f9544a0c8..2e4f7e46691133269adaa4c4f06918d02ded4f12 100644 (file)
@@ -44,7 +44,7 @@ KERNEL_VERSION = ""
 
 inherit update-alternatives
 DEPENDS_append = " update-rc.d-native"
-DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+PACKAGE_WRITE_DEPS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
 
 PACKAGES =+ "${PN}-functions"
 RDEPENDS_${PN} = "${PN}-functions \