]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: disable problematic GCC 5.2 optimizations
authorJonathan Liu <net147@gmail.com>
Mon, 21 Sep 2015 17:56:29 +0000 (03:56 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Sep 2015 16:52:46 +0000 (17:52 +0100)
This fixes systemd failing to start on Raspberry Pi 2 if it is compiled
with GCC 5.2.

It would try to start "Journal Service" and "udev Kernel Device Manager"
but fail repeatedly.

[YOCTO #8291]

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_225.bb

index f7d4c7df48373859c515b7dd0b1b950fd7da76b6..fd1a3f315a3ac444658f7d6bbeda96c31f793d72 100644 (file)
@@ -123,6 +123,9 @@ EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
 # uclibc does not have NSS
 EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
 
+# disable problematic GCC 5.2 optimizations [YOCTO #8291]
+FULL_OPTIMIZATION_append_arm = " -fno-schedule-insns -fno-schedule-insns2"
+
 do_configure_prepend() {
        export NM="${HOST_PREFIX}gcc-nm"
        export AR="${HOST_PREFIX}gcc-ar"