]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: fix for non /usr/lib libdir case
authorYu Ke <ke.yu@intel.com>
Mon, 11 Jul 2011 07:23:15 +0000 (15:23 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Jul 2011 13:52:50 +0000 (14:52 +0100)
if libdir is not /usr/lib, e.g /usr/lib64, openssl build will fail
because it still use /usr/lib as library dir.

this patch appends the configure option "--libdir" to specify the correct
library directory

Signed-off-by: Yu Ke <ke.yu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssl/openssl.inc
meta/recipes-connectivity/openssl/openssl_0.9.8r.bb

index a338f0e14a6b6782e09c0e2bc15cc31711ac67c7..d42ae1c5d5f2fbae799d077e026d002ccd392cfc 100644 (file)
@@ -93,7 +93,7 @@ do_configure () {
         if [ "x$useprefix" = "x" ]; then
                 useprefix=/
         fi        
-       perl ./Configure ${EXTRA_OECONF} shared --prefix=$useprefix --openssldir=${libdir}/ssl $target
+       perl ./Configure ${EXTRA_OECONF} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=`basename ${libdir}` $target
 }
 
 do_compile () {
index 48ec995f276179bc51d589ae30ff351d8c79d5c8..c95b1f17cdbff0b6be6f3570e36651013b4ba138 100644 (file)
@@ -1,6 +1,6 @@
 require openssl.inc
 
-PR = "r1"
+PR = "r2"
 SRC_URI += "file://debian/ca.patch \
             file://debian/config-hurd.patch;apply=no \
             file://debian/debian-targets.patch \