]> code.ossystems Code Review - openembedded-core.git/commitdiff
libc6-dbg: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Thu, 29 Mar 2018 21:33:18 +0000 (14:33 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 30 Mar 2018 08:40:25 +0000 (09:40 +0100)
Prevent bison from generating #line comments containing build
host paths references.

[YOCTO #12625]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/glibc/0030-plural_c_no_preprocessor_lines.patch [new file with mode: 0644]
meta/recipes-core/glibc/glibc_2.27.bb

diff --git a/meta/recipes-core/glibc/glibc/0030-plural_c_no_preprocessor_lines.patch b/meta/recipes-core/glibc/glibc/0030-plural_c_no_preprocessor_lines.patch
new file mode 100644 (file)
index 0000000..6f03e1c
--- /dev/null
@@ -0,0 +1,21 @@
+Improve reproducibility:
+Do not put any #line preprocessor commands in bison generated files.
+These lines contain absolute paths containing file locations on
+the host build machine.
+
+Upstream-Status: Pending
+Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
+
+diff --git a/intl/Makefile b/intl/Makefile
+index 2219717..a203780 100644
+--- a/intl/Makefile
++++ b/intl/Makefile
+@@ -151,7 +151,7 @@ $(objpfx)tst-gettext6.out: $(objpfx)tst-gettext.out
+ CPPFLAGS += -D'LOCALEDIR="$(localedir)"' \
+           -D'LOCALE_ALIAS_PATH="$(localedir)"'
+-BISONFLAGS = --yacc --name-prefix=__gettext --output
++BISONFLAGS = --yacc --no-lines --name-prefix=__gettext --output
+ $(inst_localedir)/locale.alias: locale.alias $(+force)
+       $(do-install)
index 4a461ab28344b9a1fe12582e38de5f4414c95759..772351ad46de41193122f108d6e62fcebcf2d540 100644 (file)
@@ -44,6 +44,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
            file://0027-Acquire-ld.so-lock-before-switching-to-malloc_atfork.patch \
            file://0028-bits-siginfo-consts.h-enum-definition-for-TRAP_HWBKP.patch \
            file://0029-Replace-strncpy-with-memccpy-to-fix-Wstringop-trunca.patch \
+           file://0030-plural_c_no_preprocessor_lines.patch \
 "
 
 NATIVESDKFIXES ?= ""