]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pyparsing: add from meta-oe
authorAlexander Kanavin <alex.kanavin@gmail.com>
Sat, 25 Apr 2020 17:28:09 +0000 (19:28 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Apr 2020 14:00:36 +0000 (15:00 +0100)
This is needed for python3-cython, which is needed by new python3-numpy.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-pyparsing.inc [new file with mode: 0644]
meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python-pyparsing.inc b/meta/recipes-devtools/python/python-pyparsing.inc
new file mode 100644 (file)
index 0000000..a768c97
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = "Python parsing module"
+HOMEPAGE = "http://pyparsing.wikispaces.com/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
+
+SRC_URI[md5sum] = "29733ea8cbee0291aad121c69c6e51a1"
+SRC_URI[sha256sum] = "4c830582a84fb022400b85429791bc551f1f4871c33f23e44f353119e92f969f"
+UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-debugger \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-netclient \
+    ${PYTHON_PN}-pprint \
+    ${PYTHON_PN}-stringold \
+    ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb b/meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb
new file mode 100644 (file)
index 0000000..0805fee
--- /dev/null
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyparsing.inc