]> code.ossystems Code Review - openembedded-core.git/commitdiff
Improve handling of 'all' architecture recipes and their interaction with sstate
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 23:03:02 +0000 (23:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 Oct 2011 10:34:22 +0000 (11:34 +0100)
* Jansa: rebased on current master, added nocompiler patch also to
  font-alias, dropped allarch from linux-firmware, gnome-icon-theme, hal-info as
  those are checking compiler (ie in intltool check) and better to build
  them as default arch instead of rebuilding after every machine
  change.
* this is also part of [BUGID# 1075]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12 files changed:
meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
meta/recipes-gnome/gnome/gnome-common_2.28.0.bb
meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
meta/recipes-graphics/xorg-font/encodings/nocompiler.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-font/encodings_1.0.4.bb
meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb

index 94231e0af6152c74dd04fb6ff69d4235164a31f1..8e0b215de35af85b53549ada11f97258976142bc 100644 (file)
@@ -9,15 +9,16 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
 AUTHOR = "Thomas Hood"
 HOMEPAGE = "http://packages.debian.org/resolvconf"
-DEPENDS = "bash"
 RDEPENDS_${PN} = "bash"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
 
 SRC_URI[md5sum] = "59b20258bb8a3c25b8c4083fc0279547"
 SRC_URI[sha256sum] = "37691677cea24da66d6664c98668b5f16667c0133f17feb166f246ee923ad756"
 
+inherit allarch
+
 do_compile () {
        :
 }
@@ -31,6 +32,3 @@ do_install () {
        install -m 0644 README ${D}${docdir}/${P}/
        install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
 }
-
-PACKAGE_ARCH = "all"
-
index 570c45a70364f32ef07ef609e407e4fbd03b2008..8936dbd8b9862ea585b0de0fd88e01066f59a4ca 100644 (file)
@@ -6,11 +6,8 @@ LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 SECTION = "x11/gnome"
-PR = "r0"
-inherit gnome
-
-# all isn't appropriate since STAGING_DATADIR is target specific
-# PACKAGE_ARCH="all"
+PR = "r1"
+inherit gnome allarch
 
 # The omf.make file failed if scrollkeeper doesn't happen to be
 # installed
index 55868abf7fd8510f1c11807d6e25834d6636427e..587ac40a1e4c2dc8a4eafb19003506fecee27253 100644 (file)
@@ -22,6 +22,3 @@ SRC_URI[sha256sum] = "ea7e05b77ead159379392b3b275ca0c9cbacd7d936014e447cc7c5e27a
 EXTRA_OECONF = "--disable-hicolor-check --with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
 
 inherit autotools
-
-# We can't do this until the output is shared into all target sysroots
-#PACKAGE_ARCH = "all"
index 19bb69c1f37571ea4baef621b7a748c8e4fdf0c6..b0a8242d824f1528de0f13202bff360d64e4f6e2 100644 (file)
@@ -8,11 +8,12 @@ BUGTRACKER = "https://bugzilla.redhat.com/"
 SECTION = "x11/fonts"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PACKAGE_ARCH = "all"
 RDEPENDS_${PN} = "fontconfig-utils"
-PR = "r1"
+PR = "r2"
 PE = "1"
 
+inherit allarch
+
 SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
            file://30-liberation-aliases.conf"
 
index 4882cc7be3214beadf085d53ca701baab52e98bf..5193fda3afe0b9d046deb775165ef70f07d2d187 100644 (file)
@@ -8,10 +8,9 @@ BUGTRACKER = "https://bugzilla.redhat.com/"
 SECTION = "x11/fonts"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PACKAGE_ARCH = "all"
 RDEPENDS_${PN} = "fontconfig-utils"
 PE = "1"
-PR = "r1"
+PR = "r2"
 
 FONTREV = "0.20100721"
 SRC_URI = "https://fedorahosted.org/releases/l/i/${BPN}/${BPN}-${PV}.${FONTREV}.tar.gz \
@@ -19,6 +18,8 @@ SRC_URI = "https://fedorahosted.org/releases/l/i/${BPN}/${BPN}-${PV}.${FONTREV}.
 
 S = ${WORKDIR}/${BPN}-${PV}.${FONTREV}
 
+inherit allarch
+
 do_install () {
        install -d ${D}${datadir}/fonts/ttf/
        for i in *.ttf; do
index 3294b40ae0e7b66c833c633fb0de68cc6fffcc27..682184a95d1a34df1855195487f787245168980e 100644 (file)
@@ -7,10 +7,11 @@ but is visibly different than normal and bold, and reasonably pleasing."
 SECTION = "x11/fonts"
 LICENSE = "Bitstream_Vera"
 LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
-PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r5"
 RDEPENDS_${PN} = "fontconfig-utils"
 
+inherit allarch
+
 SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2" 
 
 do_install () { 
index 002cc1569b8cad1033d0454c9d8bb37f4651c484..824c295a9675824da478857944c18c43ad7a0ca2 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 SECTION = "x11/base"
-PR="r3"
+PR = "r4"
 
 SRC_URI = "http://matchbox-project.org/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
           file://use-relative-symlinks.patch \
@@ -16,6 +16,4 @@ SRC_URI[md5sum] = "7b0c623049d4aab20600d6473f8aab23"
 SRC_URI[sha256sum] = "b26adf2d503d01299718390ae39dab4691a67220de09423be0364e9a060bf7e4"
 FILES_${PN} = "${datadir}/icons/xcursor-transparent/cursors/*"
 
-inherit autotools
-
-PACKAGE_ARCH = "all"
+inherit autotools allarch
diff --git a/meta/recipes-graphics/xorg-font/encodings/nocompiler.patch b/meta/recipes-graphics/xorg-font/encodings/nocompiler.patch
new file mode 100644 (file)
index 0000000..1cddd10
--- /dev/null
@@ -0,0 +1,31 @@
+XORG_DEFAULT_OPTIONS pulls in the following dependency chains:
+
+XORG_CWARNFLAGS -> AC_PROG_CC_C99
+XORG_STRICT_OPTION -> AC_PROG_CC_C99, XORG_CWARNFLAGS
+XORG_MANPAGE_SECTIONS -> AC_CANONICAL_HOST -> Checks host 
+
+each of which triggers the use of the host compiler. As an "all"
+architecture package, it shouldn't need a compiler (and doesn't).
+
+RP 17/5/2011
+
+Index: encodings-1.0.4/configure.ac
+===================================================================
+--- encodings-1.0.4.orig/configure.ac  2011-05-17 23:36:19.505095876 +0100
++++ encodings-1.0.4/configure.ac       2011-05-17 23:54:14.935096128 +0100
+@@ -4,12 +4,12 @@
+ AM_INIT_AUTOMAKE([foreign dist-bzip2])
+ AM_MAINTAINER_MODE
+-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+ m4_ifndef([XORG_MACROS_VERSION],
+         [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+ XORG_MACROS_VERSION(1.3)
+-XORG_DEFAULT_OPTIONS
+-
++XORG_RELEASE_VERSION
++XORG_CHANGELOG
++XORG_INSTALL
+ AC_PROG_INSTALL
+ # Require X.Org's font util macros 1.2 or later
index 13451344326d55923eb68572bb21cf2ad22bb6ff..cf7b3e3609dbcd10f9036a9321d31f44c4a03e6f 100644 (file)
@@ -7,13 +7,15 @@ require xorg-font-common.inc
 LICENSE = "PD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=9da93f2daf2d5572faa2bfaf0dbd9e76"
 PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 DEPENDS = "mkfontscale-native font-util-native"
 
-EXTRA_OECONF += "--with-encodingsdir=${datadir}/fonts/X11/encodings"
+SRC_URI += "file://nocompiler.patch"
+
+inherit allarch
 
-PACKAGE_ARCH = "all"
+EXTRA_OECONF += "--with-encodingsdir=${datadir}/fonts/X11/encodings"
 
 SRC_URI[md5sum] = "0f2d6546d514c5cc4ecf78a60657a5c1"
 SRC_URI[sha256sum] = "ced6312988a45d23812c2ac708b4595f63fd7a49c4dcd9f66bdcd50d1057d539"
index f1e8648e0833d05b9cf9f77ddf02057fe22ca53e..b1a65e7b8523ca95a752d764f5f1a1a1ed44f00b 100644 (file)
@@ -13,10 +13,11 @@ LIC_FILES_CHKSUM = "file://../misc/fonts.alias;md5=bbe8d3c0e4e74af96e3ac393985c4
 SRC_URI = "file://misc"
 
 PE = "1"
-PR = "r0"
+PR = "r1"
+
+inherit allarch
 
 PACKAGES = "${PN}"
-PACKAGE_ARCH = "all"
 FILES_${PN} = "${libdir}/X11/ ${datadir}/fonts/X11/"
 
 do_install() {
index 0eff9dd7ae5e602d90ae34fec9d740644a117006..75e029c0e8cbc87e8b329450d04f29f29338f047 100644 (file)
@@ -8,12 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2"
 SECTION = "x11"
 DEPENDS = ""
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig allarch
 
 FILES_${PN} += "${datadir}"
 
-PACKAGE_ARCH = "all"
-
 EXTRA_OECONF += "--with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
 
 #explictly setting "Sato" as default icon theme to avoid icon missing due to
index e69481de3a7b8094c317c1722e887109afdb0522..54e46277ff31f5c41babd180f3b94df7c7bdf862 100644 (file)
@@ -2,6 +2,8 @@ require sato-icon-theme.inc
 
 DEPENDS += "icon-naming-utils-native"
 
+PR = "r1"
+
 SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \
            file://iconpath-option.patch"