]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.14/4.1: fix ARM boot with gcc 5.x
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 27 Aug 2015 02:31:38 +0000 (22:31 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 30 Aug 2015 11:37:48 +0000 (12:37 +0100)
Booting qemuarm when the kernel was built with gcc 5.x would result in
a boot hang (or at least no visible output).

Updating the SRCREVs for the following change:

    Author: Jianchuan Wang
    Email: jianchuan.wang@windriver.com
    Subject: Omit to optimize vsprintf.c/kasprintf.c
    Date: Wed, 26 Aug 2015 13:54:57 +0800

    Add "-O0" for vsprintf.c/kasprintf.c

Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
While this may not be the final fix (it still has to go usptream and
be better explained), it gets us booting, so is good enough for the
time being.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto_3.14.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb

index dfbf3a2b2c1ab8ba1daf60e1c9bbd2b31530a89a..06483c3ee8b918310544335ebc8301c3770cecc0 100644 (file)
@@ -3,7 +3,7 @@ KBRANCH ?= "standard/preempt-rt"
 require recipes-kernel/linux/linux-yocto.inc
 
 SRCREV_machine ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
-SRCREV_meta ?= "92977854ff528bac281772dfb4823f4ca1513688"
+SRCREV_meta ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
index d085b0336d75d30f5aaffe3005b23fe84129a121..061205e92088d919c2526595441721eabe3f0b18 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
-SRCREV_meta ?= "92977854ff528bac281772dfb4823f4ca1513688"
+SRCREV_meta ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index db77e9ead0376a562bbe66f1ea657bfea50ae371..fc826a17c4efbfd2f9b3b1314d17fb040bcae6de 100644 (file)
@@ -11,7 +11,7 @@ KBRANCH_qemux86  ?= "standard/common-pc/base"
 KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "7e763688134a64b67f35af4f5a289be0b0c95126"
+SRCREV_machine_qemuarm ?= "9d0a4947dc7117e393dc3b8c07246d26e22ecdec"
 SRCREV_machine_qemuarm64 ?= "302ca233332fd364ecd028a0cf21b4cdc045e056"
 SRCREV_machine_qemumips ?= "9c6fdae47597756042a1d4ed613dff96e430e8e9"
 SRCREV_machine_qemuppc ?= "e4847afbb42583fa05e6a94c8d0c8f8e37ed5622"
index b1d4e5da81504b7b394e16e4c970fec6093e0663..46d46165b3592e3160cd473d8fcddd59b013ba12 100644 (file)
@@ -11,7 +11,7 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "89601a6f23a7dd842f24911f0438d0b45c85aa00"
+SRCREV_machine_qemuarm ?= "3c1245d162ccb55de1af42bcf3dbf690457bf9e4"
 SRCREV_machine_qemuarm64 ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
 SRCREV_machine_qemumips ?= "4132a691d0908d10b8f07ce7ece02e6dc94e17bc"
 SRCREV_machine_qemuppc ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
 SRCREV_machine_qemux86-64 ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
 SRCREV_machine_qemumips64 ?= "033e1aa633465449edf544eb81adda0caf16ec60"
 SRCREV_machine ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
-SRCREV_meta ?= "92977854ff528bac281772dfb4823f4ca1513688"
+SRCREV_meta ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"