]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-config: Fix poky-chroot-launch to stop dbus system bus correctly
authorRichard Purdie <richard@openedhand.com>
Wed, 30 Jan 2008 16:18:13 +0000 (16:18 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 30 Jan 2008 16:18:13 +0000 (16:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3629 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oh/qemu-config.bb
meta/packages/oh/qemu-config/poky-chroot-launch

index 3eccab99e19ab028fe8fbd9b9dcf2e439c673c96..6aed63b3389bf2b12121cf059bd7060de3eefc28 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
 LICENSE = "GPL"
 RDEPENDS = "distcc task-poky-nfs-server fakeroot oprofileui-server rsync bash"
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "file://distcc.sh \
            file://anjuta-remote-run \
index 63d98d93611577a7d1e894dbf48ba918b1032cbf..dbc432b66c0fcbb4d7044daaaac12c6679bae4bb 100755 (executable)
@@ -18,9 +18,9 @@ done
 
 bash -l
 
+# The --user option in the dbus stop script breaks under chroot
+/sbin/start-stop-daemon --stop  --pidfile /var/run/dbus/pid
+
 for S in $SERVICES; do
         fakeroot /etc/init.d/$S stop
 done
-
-# The --user option in the dbus stop script breaks under chroot
-/sbin/start-stop-daemon --stop  --pidfile /var/run/dbus/pid