]> code.ossystems Code Review - openembedded-core.git/commitdiff
trace-cmd: Add blktrace_api compatibility for TC_BARRIER
authorDarren Hart <dvhart@linux.intel.com>
Thu, 1 Dec 2011 16:07:53 +0000 (16:07 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 16:52:24 +0000 (16:52 +0000)
Newer kernels replace TC_BARRIER with TC_FLUSH. Ensure trace-cmd
can build regardless of the linux-kernel-headers version.

This is intended as a stop-gap to get the builds working again. A
proper fix will need to be discussed with the trace-cmd community.

RP: Tweaked the SRC_URI to remove unnecessary path and added PR bump
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/trace-cmd/kernelshark_1.2.bb
meta/recipes-kernel/trace-cmd/trace-cmd/blktrace-api-compatibility.patch [new file with mode: 0644]
meta/recipes-kernel/trace-cmd/trace-cmd_1.2.bb

index aa070a9d9ba51d4fcc95df352ce1bf4f5c9f75c8..d18cb6ac809814a8ea7fb0fb8db045b094fc14c6 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://kernel-shark.c;beginline=6;endline=8;md5=2c22c965a649ddd7973d7913c5634a5e"
 
 SRCREV = "7055ffd37beeb44714e86a4abc703f7e175a0db5"
-PR = "r0"
+PR = "r1"
 PV = "1.2+git${SRCPV}"
 
 DEPENDS = "gtk+"
@@ -14,7 +14,8 @@ inherit pkgconfig
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git \
            file://addldflags.patch \
-           file://make-docs-optional.patch"
+           file://make-docs-optional.patch \
+           file://blktrace-api-compatibility.patch"
 S = "${WORKDIR}/git"
 
 EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'prefix=${prefix}' gui"
diff --git a/meta/recipes-kernel/trace-cmd/trace-cmd/blktrace-api-compatibility.patch b/meta/recipes-kernel/trace-cmd/trace-cmd/blktrace-api-compatibility.patch
new file mode 100644 (file)
index 0000000..0789e9f
--- /dev/null
@@ -0,0 +1,29 @@
+trace-cmd: Add blktrace_api compatibility for TC_BARRIER
+
+Newer kernels replace TC_BARRIER with TC_FLUSH. Ensure trace-cmd
+can build regardless of the linux-kernel-headers version.
+
+Upstream-Status: Innapropriate [Stop gap]
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+
+diff --git a/plugin_blk.c b/plugin_blk.c
+index 9327b17..c8e5e1c 100644
+--- a/plugin_blk.c
++++ b/plugin_blk.c
+@@ -44,6 +44,15 @@ struct blk_data {
+       unsigned short          pdu_len;
+ };
++/*
++ * Newer kernels don't define BLK_TC_BARRIER and have replaced it with
++ * BLK_TC_FLUSH. In this case, define it here and report FLUSHES as BARRIERS as
++ * a workaround, as described in:
++ * http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=c09c47caedc9854d59378d6e34c989e51cfdd2b4
++ */
++#ifndef BLK_TC_BARRIER
++#define BLK_TC_BARRIER 1<<2
++#endif
+ static void fill_rwbs(char *rwbs, int action, unsigned int bytes)
+ {
+       int i = 0;
index 1b9231bc1231fc0094a607e9c3887a3203701c7c..d40dc6e4d0126fd734f69cfea264abc6c4b878ce 100644 (file)
@@ -4,14 +4,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://trace-cmd.c;beginline=6;endline=8;md5=2c22c965a649ddd7973d7913c5634a5e"
 
 SRCREV = "7055ffd37beeb44714e86a4abc703f7e175a0db5"
-PR = "r0"
+PR = "r1"
 PV = "1.2+git${SRCPV}"
 
 inherit pkgconfig
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git \
            file://addldflags.patch \
-           file://make-docs-optional.patch"
+           file://make-docs-optional.patch \
+           file://trace-cmd/blktrace-api-compatibility.patch"
 S = "${WORKDIR}/git"
 
 EXTRA_OEMAKE = "'prefix=${prefix}'"