]> code.ossystems Code Review - openembedded-core.git/commitdiff
go-helloworld: Turn into a go module enabled build
authorKhem Raj <raj.khem@gmail.com>
Wed, 24 Feb 2021 04:13:20 +0000 (20:13 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Feb 2021 15:16:56 +0000 (15:16 +0000)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/go-examples/go-helloworld_0.1.bb

index ab70ea98a32643af80269109cec9201bd7f394cc..d3f7525dc9840511d9027d074ec827489bab2a2e 100644 (file)
@@ -6,13 +6,14 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
 
 SRC_URI = "git://${GO_IMPORT}"
-SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
+SRCREV = "bcf50bfd7dcd8020c90965747d857ae42802e0c5"
 UPSTREAM_CHECK_COMMITS = "1"
 
 GO_IMPORT = "github.com/golang/example"
 GO_INSTALL = "${GO_IMPORT}/hello"
+GO_WORKDIR = "${GO_INSTALL}"
 
-inherit go
+inherit go-mod
 
 # This is just to make clear where this example is
 do_install_append() {