]> code.ossystems Code Review - openembedded-core.git/commitdiff
libowl: Use autotools_stage instead of broken custom staging function
authorEnric Balletbo i Serra <eballetbo@gmail.com>
Thu, 9 Jul 2009 18:35:30 +0000 (20:35 +0200)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 9 Jul 2009 20:58:47 +0000 (21:58 +0100)
This patch also fixes claws-mail, leafpad, pcmanfm, pimlico and puzzles
recipes using the proper include for owlwindowmenu.h

Signed-off-by: Enric Balletbo i Serra <eballetbo@gmail.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
15 files changed:
meta/packages/claws-mail/claws-mail.inc
meta/packages/claws-mail/files/owl-window-menu.patch
meta/packages/leafpad/files/owl-menu.patch
meta/packages/leafpad/leafpad_0.8.9.bb
meta/packages/libowl/libowl_svn.bb
meta/packages/pcmanfm/files/owl-window-menu.patch
meta/packages/pcmanfm/pcmanfm_0.3.2.2.bb
meta/packages/pimlico/contacts_0.9.bb
meta/packages/pimlico/dates_0.4.6.bb
meta/packages/pimlico/files/contacts-owl-window-menu.patch
meta/packages/pimlico/files/dates-owl-window-menu.patch
meta/packages/pimlico/files/tasks-owl.diff
meta/packages/pimlico/tasks_0.13.bb
meta/packages/puzzles/files/oh-puzzles-owl-menu.patch
meta/packages/puzzles/oh-puzzles_svn.bb

index fcd4a1dd7fcbc64a43bf0e8dfa0569f3289e6433..029e769fc8527570ffd2488cb1d541d8b8fa38f0 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Mail user agent"
 #DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell openssl"
 DEPENDS = "gtk+ libetpan openssl libowl"
 LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "\
        ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2   \
index 26aeab2b118709e2afbc36d6656bd8a7b1efe7ad..54c61668a9c6789e4b175e2bd723e11a4ab1ccba 100644 (file)
@@ -22,7 +22,7 @@ Index: claws-mail-2.9.1/src/gtk/menu.c
 -#include <hildon-widgets/hildon-program.h>
 -#include <gtk/gtkmain.h>
 -#endif
-+#include "owlwindowmenu.h"
++#include <libowl/owlwindowmenu.h>
  
  static void connect_accel_change_signals(GtkWidget* widget, GtkWidget *wid2) ;
  
index bcb591744020bbf15468198d90d97e5417bf51ca..acfc880307ae492a330ef3aa462c514c0e784bab 100644 (file)
@@ -16,7 +16,7 @@
   */
  
  #include "leafpad.h"
-+#include "owlwindowmenu.h"
++#include <libowl/owlwindowmenu.h>
 +
  /*
  static void cb_scroll_event(GtkAdjustment *adj, GtkWidget *view)
index c5f63aa83983938bf5efece708cd8db886a57fac..f99fa0acfa99a3964574cd5915ae61caf202a1e1 100644 (file)
@@ -3,7 +3,7 @@ DEPENDS = "gtk+ intltool-native libowl"
 SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
           file://owl-menu.patch;patch=1                                \
           file://leafpad.desktop"
-PR = "r7"
+PR = "r8"
 
 inherit autotools pkgconfig
 
index c6aacdf75c20afb0e08b4e0aedf506d61e809458..80dcb6b861c67b867b58e43f62ed3e3a2cb7e0e8 100644 (file)
@@ -21,19 +21,4 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
 
 S = "${WORKDIR}/${PN}"
 
-inherit autotools pkgconfig
-
-do_compile_prepend() {
-       # have to unstage the library first so that the tests build
-       rm -f ${STAGING_LIBDIR}/libowl.*
-       rm -f ${STAGING_INCDIR}/owl*.h
-}
-
-do_stage() {
-       headers=`eval ls libowl/owl*.h`
-       for header in $headers; do
-               hdr_base=`eval basename $header`
-               install -m 644 $header ${STAGING_INCDIR}/$hdr_base
-       done
-       install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/
-}
+inherit autotools_stage pkgconfig
index 31eba8683b5105244eca40b330f391a2831ce6ea..7db68f4b127f1be2aa965fbd84393aa218833f66 100644 (file)
@@ -38,7 +38,7 @@ Index: pcmanfm-0.3.2-beta/src/main.c
  #include "glade-support.h"
  #include "settings.h"
  
-+#include "owlwindowmenu.h"
++#include "libowl/owlwindowmenu.h"
 +
  static char* init_path = NULL;
  
index a62b1dac2951d83e6f39a0c8b243e66602e37fb2..424e96416ddcc13857af300de71cadb4b2ae4a65 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "x11"
 PRIORITY = "optional"
 DEPENDS = "gtk+ libowl startup-notification"
 
-PR="r2"
+PR="r3"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
           file://gnome-fs-directory.png \
index d3ecf29ce8c2faabd85a256a4fb275cddaec94d3..d00752b9c44e5c99f7aea51c7b91c0ccba36e941 100644 (file)
@@ -1,6 +1,6 @@
 require contacts.inc
 
-PR="r0"
+PR="r1"
 
 SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \
           file://stock_contact.png \
index a8ec63188b84f091bb33df520befbac87b9a3aa9..cb452994ac178ab3062789f70c9ca8052a772813 100644 (file)
@@ -1,5 +1,7 @@
 require dates.inc
 
+PR = "r1"
+
 SRC_URI = "http://pimlico-project.org/sources/dates/dates-${PV}.tar.gz \
           file://dates-owl-window-menu.patch;patch=1 \
          "
index ff201b832163f60562c0e9f8c4e281c122a5a5c8..4b9238b43ae7f6c40b95f4fd109a0e12f616bb81 100644 (file)
@@ -34,7 +34,7 @@ Index: contacts-0.9/src/contacts-main.c
  #include <libgnomevfs/gnome-vfs.h>
  #endif
  
-+#include "owlwindowmenu.h"
++#include <libowl/owlwindowmenu.h>
 +
  #include "bacon-message-connection.h"
  #include "contacts-defs.h"
index 6bde252ac3a3f0166893177288dc6bdd3c8f924c..a52fd5741bd6ba0c764909008970b9067a47f532 100644 (file)
@@ -58,7 +58,7 @@
  #include <gconf/gconf-client.h>
  
 +#include <gtk/gtkmenuitem.h>
-+#include "owlwindowmenu.h"
++#include <libowl/owlwindowmenu.h>
  #include "dates_types.h"
  #include "dates_platform.h"
  #include "dates_callbacks.h"
index ce1ed9db7e56c2077920f6f62fa296158758e916..e4078066f5c69f2b82fcfba0b68e8409edadc1d6 100644 (file)
@@ -32,7 +32,7 @@ Index: src/gtk/main.c
  #include <libecal/e-cal.h>
  #include <glib/gi18n.h>
  #include <gtk/gtk.h>
-+#include <owlwindowmenu.h>
++#include <libowl/owlwindowmenu.h>
  
  #include <libkoto/ical-util.h>
  #include <libkoto/koto-actions.h>
index 736e07624ceff668d89e36538cd64d883ba5ea14..5d41222944566ca91560d2f2bc61d627af4e9896 100644 (file)
@@ -4,4 +4,4 @@ SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \
            file://fix_configure.patch;patch=1;status=merged \
            file://tasks-owl.diff;patch=1;pnum=0"
 
-PR = "r1"
+PR = "r2"
index 99d40144d047d45dc53a72f660011aeaf53d580c..61da9191a8c8b7b4d8265df8ce0316be63cef76a 100644 (file)
@@ -6,7 +6,7 @@ Index: src/gtk.c
  #include <gdk/gdkx.h>
  #include <gdk-pixbuf/gdk-pixbuf.h>
  
-+#include <owlwindowmenu.h>
++#include <libowl/owlwindowmenu.h>
 +
  #include <librsvg/rsvg.h>
  
index 1c6ca47f52c4557283d0653c9ead8e19d1244df5..f027dc1bb31808b51a446a8d7443ca0ed1cb42cb 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "x11"
 DEPENDS = "gtk+ gconf intltool-native librsvg libowl"
 
 PV = "0.1+svnr${SRCREV}"
-PR = "r7"
+PR = "r8"
 
 bindir = "/usr/games"