]> code.ossystems Code Review - openembedded-core.git/commitdiff
replace portmap with rpcbind.
authorRoy.Li <rongqing.li@windriver.com>
Mon, 24 Dec 2012 01:02:04 +0000 (09:02 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Dec 2012 09:42:48 +0000 (09:42 +0000)
Rpcbind has more features, like ipv6 support and nfs4 support;
Redhat, Fedora, debian, Ubuntu are using rpcbind by default.

Signed-off-by: Roy.Li <rongqing.li@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh
meta/recipes-core/packagegroups/packagegroup-base.bb

index 5a4a7e7cbfa4e900823bea42a458146e23380c16..84b8e763158ce3f557a1cb114c58559c0476a931 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
 
 # util-linux for libblkid
 DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
-RDEPENDS_${PN} = "portmap"
+RDEPENDS_${PN} = "rpcbind"
 RRECOMMENDS_${PN} = "kernel-module-nfsd"
 
 PR = "r5"
index 82ec7f66eb6cd93e73e05c1aae7fe88af661562c..4fffe4e8083c1322efea86be62a9d477e98c08f1 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh
 ### BEGIN INIT INFO
 # Provides:          mountnfs
-# Required-Start:    $local_fs $network $portmap
+# Required-Start:    $local_fs $network $rpcbind
 # Required-Stop:
 # Default-Start:     S
 # Default-Stop:
@@ -17,9 +17,9 @@ test -f /etc/fstab && (
 #
 #      Read through fstab line by line. If it is NFS, set the flag
 #      for mounting NFS filesystems. If any NFS partition is found and it
-#      not mounted with the nolock option, we start the portmapper.
+#      not mounted with the nolock option, we start the rpcbind.
 #
-portmap=no
+rpcbind=no
 mount_nfs=no
 mount_smb=no
 mount_ncp=no
@@ -45,7 +45,7 @@ do
                        *nolock*)
                                ;;
                        *)
-                               portmap=yes
+                               rpcbind=yes
                                ;;
                esac
        fi
@@ -65,12 +65,12 @@ done
 
 exec 0>&1
 
-if test "$portmap" = yes
+if test "$rpcbind" = yes
 then
-       if test -x /sbin/portmap
+       if test -x /usr/sbin/rpcbind
        then
-               echo -n "Starting portmapper... "
-               start-stop-daemon --start --quiet --exec /sbin/portmap
+               echo -n "Starting rpcbind... "
+               start-stop-daemon --start --quiet --exec /usr/sbin/rpcbind
                sleep 2
        fi
 fi
index 4ab34bbce469f5714f32d520a3ef69c032154234..100cc88be3b17ea885ed03625c50caf9411d7b08 100644 (file)
@@ -331,7 +331,7 @@ RRECOMMENDS_packagegroup-base-cramfs = "\
 #
 SUMMARY_packagegroup-base-nfs = "NFS network filesystem support"
 RDEPENDS_packagegroup-base-nfs = "\
-    portmap"
+    rpcbind"
 
 RRECOMMENDS_packagegroup-base-nfs = "\
     kernel-module-nfs "