]> code.ossystems Code Review - openembedded-core.git/commitdiff
metacity-clutter_git: Set correct gconf keys after installation for compositing.
authorJoshua Lock <josh@linux.intel.com>
Fri, 2 Jan 2009 12:17:20 +0000 (12:17 +0000)
committerJoshua Lock <josh@linux.intel.com>
Mon, 5 Jan 2009 11:53:08 +0000 (11:53 +0000)
The clutter-plugin name has changed since the recipe was first written so we now set the right plugin name as well as enabling compositing.

meta/packages/gnome/metacity-clutter_git.bb

index e06714ccda579027f326d0bfa8b0f944db96fa5b..127994cf213a77b3c9d8ad67f762af5f36b3c1d4 100644 (file)
@@ -2,7 +2,7 @@ SECTION = "x11/wm"
 DESCRIPTION = "Metacity is the boring window manager for the adult in you."
 LICENSE = "GPL"
 DEPENDS = "startup-notification gtk+ gconf clutter-0.8 gdk-pixbuf-csource-native"
-PR = "r4"
+PR = "r5"
 PV = "2.25.1+git${SRCREV}"
 inherit gnome update-alternatives
 
@@ -34,6 +34,8 @@ fi
 
 . ${sysconfdir}/init.d/functions
 
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[simple]'
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[default]'
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/metacity/general/compositing_manager true
 }