]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-setuptools-scm: move from meta-python
authorTim Orling <timothy.t.orling@linux.intel.com>
Sat, 28 Nov 2020 04:24:21 +0000 (20:24 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Nov 2020 14:40:55 +0000 (14:40 +0000)
The blessed package to manage your versions by scm tags

* Part of the dependency chain for pytest

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb b/meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb
new file mode 100644 (file)
index 0000000..4ebbac6
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY = "the blessed package to manage your versions by scm tags"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "e6c9fad17c90516d640868eb833d5150"
+SRC_URI[sha256sum] = "a8994582e716ec690f33fec70cca0f85bd23ec974e3f783233e4879090a7faa8"
+
+PYPI_PACKAGE = "setuptools_scm"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+    ${PYTHON_PN}-debugger \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-py \
+    ${PYTHON_PN}-setuptools \
+"
+RDEPENDS_${PN}_class-native = "\
+    ${PYTHON_PN}-setuptools-native \
+"
+
+BBCLASSEXTEND = "native nativesdk"