]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add gcc-native
authorRichard Purdie <richard@openedhand.com>
Tue, 15 Jan 2008 09:52:24 +0000 (09:52 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 15 Jan 2008 09:52:24 +0000 (09:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3487 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gcc/gcc-native.inc [new file with mode: 0644]
meta/packages/gcc/gcc-native_3.4.4.bb [new file with mode: 0644]

diff --git a/meta/packages/gcc/gcc-native.inc b/meta/packages/gcc/gcc-native.inc
new file mode 100644 (file)
index 0000000..3cf20a4
--- /dev/null
@@ -0,0 +1,28 @@
+DEPENDS = ""
+PACKAGES = ""
+PROVIDES = "gcc-native-${PV}"
+
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+               --with-newlib \
+               --disable-shared \
+               --disable-threads \
+               --disable-multilib \
+               --disable-__cxa_atexit \
+               --enable-languages=c \
+               --enable-target-optspace \
+               --program-prefix=${TARGET_PREFIX}"
+
+do_install () {
+       :
+}
+
+do_stage () {
+       cd gcc
+       oe_runmake install-common install-headers install-libgcc
+       install -m 0755 xgcc ${STAGING_BINDIR}/gcc-${PV}
+}
diff --git a/meta/packages/gcc/gcc-native_3.4.4.bb b/meta/packages/gcc/gcc-native_3.4.4.bb
new file mode 100644 (file)
index 0000000..2e5d3ac
--- /dev/null
@@ -0,0 +1,2 @@
+require gcc_${PV}.bb
+require gcc-native.inc