]> code.ossystems Code Review - openembedded-core.git/commitdiff
Rename the remaining poky-* scripts to oe-* or runqemu-*
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Apr 2011 22:24:51 +0000 (23:24 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Apr 2011 22:46:46 +0000 (23:46 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
17 files changed:
.gitignore
meta/classes/image.bbclass
meta/conf/site.conf.sample
meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
scripts/oe-find-native-sysroot [moved from scripts/poky-find-native-sysroot with 97% similarity]
scripts/oe-git-proxy-command [moved from scripts/poky-git-proxy-command with 100% similarity]
scripts/oe-git-proxy-socks-command [new file with mode: 0755]
scripts/oe-git-proxy-socks.c [moved from scripts/poky-git-proxy-socks.c with 100% similarity]
scripts/oe-setup-rpmrepo [moved from scripts/poky-setup-rpmrepo with 100% similarity]
scripts/oe-trim-schemas [moved from scripts/poky-trim-schemas with 100% similarity]
scripts/poky-git-proxy-socks-command [deleted file]
scripts/runqemu-addptable2image [moved from scripts/poky-addptable2image with 100% similarity]
scripts/runqemu-export-rootfs [moved from scripts/poky-export-rootfs with 96% similarity]
scripts/runqemu-extract-sdk [moved from scripts/poky-extract-sdk with 95% similarity]
scripts/runqemu-gen-tapdevs [moved from scripts/poky-gen-tapdevs with 100% similarity]
scripts/runqemu-ifup
scripts/runqemu-internal

index c563983906eab5bd35082442576278fdb6d21d5e..b13086deb79d6f5e8a8940c3d8483cffa568bce8 100644 (file)
@@ -7,7 +7,7 @@ build/tmp/
 build/sstate-cache
 build/pyshtables.py
 pstage/
-scripts/poky-git-proxy-socks
+scripts/oe-git-proxy-socks
 sources/
 meta-darwin
 meta-maemo
index 7d31d04a2437acf53b4809476bc842e076d9a7ab..b2325b3a6dfb8281dbc2a3f607fe6487bd717ede 100644 (file)
@@ -216,7 +216,7 @@ rootfs_trim_schemas () {
        do
                # Need this in case no files exist
                if [ -e $schema ]; then
-                       poky-trim-schemas $schema > $schema.new
+                       oe-trim-schemas $schema > $schema.new
                        mv $schema.new $schema
                fi
        done
index 469a1660f5598fbd9a1d913e2571321c2564cadd..d438298e8447728b9e1d464cf700895defae3d9b 100644 (file)
@@ -20,7 +20,7 @@ SCONF_VERSION = "1"
 # although this only works for http
 #GIT_PROXY_HOST = "proxy.example.com"
 #GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-command"
 
 # GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
 #GIT_CORE_CONFIG = "Yes"
@@ -28,11 +28,11 @@ SCONF_VERSION = "1"
 #GIT_PROXY_IGNORE_2 = "another.server.com"
 
 # If SOCKS is available run the following command to comple a simple transport
-# gcc scripts/poky-git-proxy-socks.c -o poky-git-proxy-socks
+# gcc scripts/oe-git-proxy-socks.c -o oe-git-proxy-socks
 # and then share that binary somewhere in PATH, then use the following settings
 #GIT_PROXY_HOST = "proxy.example.com"
 #GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-socks-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-socks-command"
 
 
 # Uncomment this to use a shared download directory
index 10d3e64ae87118a328e512d5ad3bfd1a858075c4..15f872beffa6821f53b124bfa364c701f88cdfb9 100644 (file)
@@ -11,13 +11,13 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5
 
 SRC_URI = "file://${COREBASE}/scripts/runqemu \
            file://${COREBASE}/scripts/runqemu-internal \
-           file://${COREBASE}/scripts/poky-addptable2image \
-           file://${COREBASE}/scripts/poky-gen-tapdevs \
+           file://${COREBASE}/scripts/runqemu-addptable2image \
+           file://${COREBASE}/scripts/runqemu-gen-tapdevs \
            file://${COREBASE}/scripts/runqemu-ifup \
            file://${COREBASE}/scripts/runqemu-ifdown \
-           file://${COREBASE}/scripts/poky-find-native-sysroot \
-           file://${COREBASE}/scripts/poky-extract-sdk \
-           file://${COREBASE}/scripts/poky-export-rootfs \
+           file://${COREBASE}/scripts/oe-find-native-sysroot \
+           file://${COREBASE}/scripts/runqemu-extract-sdk \
+           file://${COREBASE}/scripts/runqemu-export-rootfs \
            file://tunctl.c \
            file://raw2flash.c \
           "
@@ -34,7 +34,8 @@ do_compile() {
 
 do_install() {
        install -d ${D}${bindir}
-       install -m 0755 ${WORKDIR}${COREBASE}/scripts/poky-* ${D}${bindir}/
+       install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
+       install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
        install tunctl ${D}${bindir}/
        install raw2flash.spitz ${D}${bindir}/
        install flash2raw.spitz ${D}${bindir}/
similarity index 97%
rename from scripts/poky-find-native-sysroot
rename to scripts/oe-find-native-sysroot
index d44fd9536ecf6c675886bc88f60dda69cf211073..da00a078507ba93f9524d5501b5e1f319500c403 100755 (executable)
@@ -8,7 +8,7 @@
 # This script is intended to be run within other scripts by source'ing
 # it, e.g:
 #
-# SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+# SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 # . $SYSROOT_SETUP_SCRIPT
 #
 # This script will terminate execution of your calling program unless
diff --git a/scripts/oe-git-proxy-socks-command b/scripts/oe-git-proxy-socks-command
new file mode 100755 (executable)
index 0000000..90fa14e
--- /dev/null
@@ -0,0 +1,2 @@
+#! /bin/bash
+oe-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@
diff --git a/scripts/poky-git-proxy-socks-command b/scripts/poky-git-proxy-socks-command
deleted file mode 100755 (executable)
index a5af2d3..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#! /bin/bash
-poky-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@
similarity index 96%
rename from scripts/poky-export-rootfs
rename to scripts/runqemu-export-rootfs
index 764d19a823766b34e16af0d29f4fda175b40c28d..0076768d20d0837ec93407b94e9e239f44fb4720 100755 (executable)
@@ -38,9 +38,9 @@ fi
 # Ensure the nfs-export-dir is an absolute path
 NFS_EXPORT_DIR=$(cd "$2" && pwd)
 
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
-    echo "Error: Unable to find the poky-find-native-sysroot script"
+    echo "Error: Unable to find the oe-find-native-sysroot script"
     echo "Did you forget to source your Poky environment script?"
     exit 1
 fi
@@ -73,7 +73,7 @@ export PSEUDO_LOCALSTATEDIR
 
 if [ ! -d "$PSEUDO_LOCALSTATEDIR" ]; then
        echo "Error: $PSEUDO_LOCALSTATEDIR does not exist."
-       echo "Did you create the export directory using poky-extract-sdk?"
+       echo "Did you create the export directory using runqemu-extract-sdk?"
        exit 1  
 fi
 
similarity index 95%
rename from scripts/poky-extract-sdk
rename to scripts/runqemu-extract-sdk
index ee2682e74a12e1677d97f5d613d80f6aa2e64e01..ed349dd306cbaf37417c209e498cb2cfa134a3bc 100755 (executable)
@@ -29,9 +29,9 @@ if [ $# -ne 2 ]; then
        exit 1
 fi
 
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
-    echo "Error: Unable to find the poky-find-native-sysroot script"
+    echo "Error: Unable to find the oe-find-native-sysroot script"
     echo "Did you forget to source your Poky environment script?"
     exit 1
 fi
index c963af5df903d4cb62902a9cf365167120e161ba..a3914140a6fa069f9c04fa840ef08d922b95c4fa 100755 (executable)
@@ -14,7 +14,7 @@
 # <my-username> ALL=NOPASSWD: /path/to/runqemu-ifdown
 #
 # If you'd like to create a bank of tap devices at once, you should use
-# the poky-gen-tapdevs script instead. If tap devices are set up using
+# the runqemu-gen-tapdevs script instead. If tap devices are set up using
 # that script, the runqemu script will never end up calling this
 # script.
 #
index 64374f2076f02e8a3a6b35b48bacbd332ffd6cb0..adf2b47aae3204ecf366d7c1b19d007f4c9022b6 100755 (executable)
@@ -83,7 +83,7 @@ fi
 if [ -z "$mem_set" ] ; then
   SCRIPT_QEMU_EXTRA_OPT="$SCRIPT_QEMU_EXTRA_OPT -m $mem_size"
 fi
-# This file is created when poky-gen-tapdevs creates a bank of tap
+# This file is created when runqemu-gen-tapdevs creates a bank of tap
 # devices, indicating that the user should not bring up new ones using
 # sudo.
 NOSUDO_FLAG="/etc/poky-nosudo"
@@ -186,8 +186,8 @@ cleanup() {
 
     if [ "$NFSRUNNING" = "true" ]; then
         echo "Shutting down the userspace NFS server..."
-        echo "poky-export-rootfs stop $ROOTFS"
-        poky-export-rootfs stop $ROOTFS
+        echo "runqemu-export-rootfs stop $ROOTFS"
+        runqemu-export-rootfs stop $ROOTFS
     fi
     # If QEMU crashes or somehow tty properties are not restored
     # after qemu exits, we need to run stty sane
@@ -258,8 +258,8 @@ if [ "$FSTYPE" = "nfs" ]; then
     fi
 
     # Start the userspace NFS server
-    echo "poky-export-rootfs restart $ROOTFS"
-    poky-export-rootfs restart $ROOTFS
+    echo "runqemu-export-rootfs restart $ROOTFS"
+    runqemu-export-rootfs restart $ROOTFS
     if [ $? != 0 ]; then
         cleanup
         return
@@ -351,7 +351,7 @@ if [ "$MACHINE" = "spitz" ]; then
         echo $ROOTFS
         if [ ! -e "$ROOTFS.qemudisk" ]; then
             echo "Adding a partition table to the ext3 image for use by QEMU, please wait..."
-            poky-addptable2image $ROOTFS $ROOTFS.qemudisk
+            runqemu-addptable2image $ROOTFS $ROOTFS.qemudisk
         fi
         QEMUOPTIONS="$QEMU_NETWORK_CMD -M spitz -hda $ROOTFS.qemudisk -portrait"
     fi