]> code.ossystems Code Review - openembedded-core.git/commitdiff
diffoscope: add native libraries to LD_LIBRARY_PATH
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 5 May 2021 15:18:50 +0000 (17:18 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 May 2021 07:41:21 +0000 (08:41 +0100)
Reversal of global setting in previous commit necessitates
a local fix, otherwise, this happens:

  File "/home/pokybuild/yocto-worker/reproducible-debian/build/build-st-52142/tmp/work/x86_64-linux/diffoscope-native/172-r0/recipe-sysroot-native/usr/lib/python3.9/ctypes/__init__.py", line 392, in __getitem__
    func = self._FuncPtr((name_or_ordinal, self))
AttributeError: nativepython3: undefined symbol: archive_errno

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/diffoscope/diffoscope_172.bb

index bf4726e77896f52157b535755658747411e15188..86dd5d8d70bb60463907311d877956070edb9121 100644 (file)
@@ -23,6 +23,7 @@ do_install_append_class-native() {
        create_wrapper ${D}${bindir}/diffoscope \
                MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
                RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
+               LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
                RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
 }