]> code.ossystems Code Review - openembedded-core.git/commitdiff
bootchart2: fix to find collector correctly in case of multilib
authorChen Qi <Qi.Chen@windriver.com>
Tue, 2 Dec 2014 10:26:06 +0000 (18:26 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 10:17:37 +0000 (10:17 +0000)
This patch fixes the following error of being not able to find the
bootchart-collector program when using bootchart2 in multilib system.

In order for bootchartd to correctly find the collector program, we need
to set several vars while compiling.

(From OE-Core rev: 26518bea1d6aa0e438e6492c2af70225b431d7a1)

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/bootchart2/bootchart2_git.bb

index 04fb901b68a8aeb4b066c093541c612a2dcc3ed0..5fc7211f7980d7f38f835356be4d8b4b128c462f 100644 (file)
@@ -120,6 +120,12 @@ do_compile_append_class-native () {
     chmod +x ${S}/pybootchartgui
 }
 
+do_compile_prepend () {
+    export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
+    export BINDIR="${bindir}"
+    export LIBDIR="${base_libdir}"
+}
+
 do_install () {
     install -d ${D}${sysconfdir} # needed for -native
     export PY_LIBDIR="${libdir}/${PYTHON_DIR}"