]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add run-postinsts. This runs any remaining postinstall scripts without needing ipkg...
authorRichard Purdie <richard@openedhand.com>
Mon, 5 Nov 2007 16:08:56 +0000 (16:08 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 5 Nov 2007 16:08:56 +0000 (16:08 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3069 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/run-postinsts/run-postinsts [new file with mode: 0755]
meta/packages/meta/run-postinsts/run-postinsts.awk [new file with mode: 0644]
meta/packages/meta/run-postinsts_1.0.bb [new file with mode: 0644]

diff --git a/meta/packages/meta/run-postinsts/run-postinsts b/meta/packages/meta/run-postinsts/run-postinsts
new file mode 100755 (executable)
index 0000000..334a39b
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# Copyright 2007 Openedhand Ltd.
+#
+# Author: Richard Purdie <rpurdie@openedhand.com>
+#
+
+PKGSYSTEM=/usr/lib/ipkg
+STAMP=$PKGSYSTEM/postinsts-done
+STATFILE=$PKGSYSTEM/status
+STATFILE2=$PKGSYSTEM/status2
+
+if [ -e $STAMP ]; then
+  exit 0
+fi
+
+awk -f /usr/share/run-postinsts/run-postinsts.awk $STATFILE > $STATFILE2
+if [ $? = 0 ]; then
+  mv $STATFILE2 $STATFILE
+  touch $STAMP
+  exit 0
+else
+  rm -f $STATFILE2
+  rm -f $STAMP
+  exit 1
+fi
diff --git a/meta/packages/meta/run-postinsts/run-postinsts.awk b/meta/packages/meta/run-postinsts/run-postinsts.awk
new file mode 100644 (file)
index 0000000..1532577
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright 2007 Openedhand Ltd.
+#
+# Author: Richard Purdie <rpurdie@openedhand.com>
+#
+# Rather hacky proof of concept
+#
+
+BEGIN {
+  package=""
+}
+/Package:.*/ {
+  package = substr($0, 10)
+}
+/Status:.*unpacked.*/ {
+  print "Configuring: " package > "/dev/stderr"
+  ret = system("/usr/lib/ipkg/info/" package ".postinst 1>&2")
+  if (ret == 0)
+    $0 = gensub("unpacked", "installed", 1)
+  else
+    print "Postinstall failed for " package > "/dev/stderr"
+}
+{
+  print $0
+}
diff --git a/meta/packages/meta/run-postinsts_1.0.bb b/meta/packages/meta/run-postinsts_1.0.bb
new file mode 100644 (file)
index 0000000..b095adc
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "Run postinstall scripts on device using awk"
+SECTION = "devel"
+PR = "r0"
+
+SRC_URI = "file://run-postinsts file://run-postinsts.awk"
+
+INITSCRIPT_NAME = "run-postinsts"
+INITSCRIPT_PARAMS = "start 98 S ."
+
+inherit update-rc.d
+
+do_configure() {
+       :
+}
+
+do_compile () {
+       :
+}
+
+do_install() {
+       install -d ${D}${sysconfdir}/init.d/
+       install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
+
+       install -d ${D}${datadir}/${PN}/
+       install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${PN}/
+}
+
+do_stage () {
+       :
+}