]> code.ossystems Code Review - openembedded-core.git/commitdiff
enchant: refactor packages for staticdev
authorSaul Wold <sgw@linux.intel.com>
Thu, 19 Jan 2012 00:02:32 +0000 (16:02 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2012 11:29:06 +0000 (11:29 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/enchant/enchant_1.6.0.bb

index a3ef37912ac8f084945b1ea052a51f4395400485..25178f57c86c5c42f51cb53e01e7167660122623 100644 (file)
@@ -10,7 +10,7 @@ RDEPENDS_${PN}    = "aspell"
 
 inherit autotools pkgconfig
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
 
@@ -20,6 +20,7 @@ SRC_URI[sha256sum] = "2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03
 EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc"
 
 FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so"
-FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la ${libdir}/${PN}/*.a" 
+FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la" 
+FILES_${PN}-staticdev += "${libdir}/${PN}/*.a" 
 
 export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "