]> code.ossystems Code Review - openembedded-core.git/commitdiff
sgml-common-native: Read a catalog backup to repopulate sgml-docbook.cat
authorSaul Wold <sgw@linux.intel.com>
Fri, 29 Jul 2011 00:08:36 +0000 (17:08 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2011 12:58:14 +0000 (13:58 +0100)
This reads the sgml-docbook.bak and adds the entries into sgml-docbook.cat since
this occurs out of order during shared state sysroot populate.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb

index 2c8d874eb70a34a516e754c436e35ec10717178e..af7e104274d81272eeff46d278609ba16c12410d 100644 (file)
@@ -13,7 +13,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b"
 SECTION = "base"
 
-PR = "r0"
+PR = "r1"
 
 require sgml-common_${PV}.bb
 inherit native
@@ -21,6 +21,8 @@ inherit native
 S = "${WORKDIR}/sgml-common-${PV}"
 
 SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle"
+SSTATEPOSTINSTFUNCS += "sgml_common_sstate_postinst"
+
 
 do_install_append() {
        # install-catalog script contains hard-coded references to
@@ -46,3 +48,17 @@ sgml_common_native_mangle () {
        # Remove ${D} path from catalog file created by install-catalog script
        sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog
 }
+
+sgml_common_sstate_postinst() {
+       if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+       then
+               if [ -e ${sysconfdir}/sgml/sgml-docbook.bak ]; then
+                       for catalog in `awk '{print $2}' ${sysconfdir}/sgml/sgml-docbook.bak`; do
+                               if [ ! `grep $catalog ${sysconfdir}/sgml/sgml-docbook.cat 1> /dev/null 2>&1` ]; then
+                                       ${bindir}/install-catalog \
+                                               --add ${sysconfdir}/sgml/sgml-docbook.cat $catalog
+                               fi
+                       done
+               fi
+       fi
+}