]> code.ossystems Code Review - openembedded-core.git/commitdiff
default-distrovars: Add DISTRO_FEATURES_INITMAN to DISTRO_FEATURES
authorRadu Moisan <radu.moisan@intel.com>
Sat, 19 Jan 2013 22:47:04 +0000 (22:47 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 20 Jan 2013 12:44:14 +0000 (12:44 +0000)
This is a more generic way to set the init manager since we
plan to support other init managers as well.
I will use this variable as a switch to turn on/off any
init scheme that we might support in the future.
By default we use sysvinit.

Signed-off-by: Radu Moisan <radu.moisan@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/default-distrovars.inc
meta/recipes-core/packagegroups/packagegroup-core-boot.bb

index 9002fd6f43b06c0a4ffc9f35375f47eddb78bdfc..f07354771aaa54b159cb9e6c9e0062c870298211 100644 (file)
@@ -19,7 +19,8 @@ DISTRO_FEATURES_LIBC_DEFAULT ?= "ipv4 ipv6 libc-backtrace libc-big-macros libc-b
                                        libc-posix-wchar-io"
 DISTRO_FEATURES_LIBC ?= "${DISTRO_FEATURES_LIBC_DEFAULT}"
 DISTRO_FEATURES_LIBC_class-nativesdk = "${DISTRO_FEATURES_LIBC_DEFAULT}"
-DISTRO_FEATURES ?= "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g x11 ${DISTRO_FEATURES_LIBC}"
+DISTRO_FEATURES_INITMAN ?= "sysvinit"
+DISTRO_FEATURES ?= "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g x11 ${DISTRO_FEATURES_LIBC} ${DISTRO_FEATURES_INITMAN}"
 
 IMAGE_FEATURES ?= ""
 
index 16ad4e3ef89ba0a3cf6549eef062f7925e89da00..94e9e32f0bc22421e6ab577804fbe9f9336ed9f3 100644 (file)
@@ -26,7 +26,7 @@ RCONFLICTS_${PN} = "task-core-boot"
 # Distro can override the following VIRTUAL-RUNTIME providers:
 VIRTUAL-RUNTIME_dev_manager ?= "udev"
 VIRTUAL-RUNTIME_login_manager ?= "tinylogin"
-VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
+VIRTUAL-RUNTIME_init_manager ?= "${DISTRO_FEATURES_INITMAN}"
 VIRTUAL-RUNTIME_initscripts ?= "initscripts"
 VIRTUAL-RUNTIME_keymaps ?= "keymaps"