]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxrender: CVE-2016-7949
authorSona Sarmadi <sona.sarmadi@enea.com>
Fri, 27 Jan 2017 07:26:12 +0000 (08:26 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Feb 2017 11:59:59 +0000 (11:59 +0000)
Insufficient validation of server responses results
in overflow of previously reserved memory

Upstream patch:
https://cgit.freedesktop.org/xorg/lib/libXrender/commit/?id=9362c7ddd1af3b168953d0737877bc52d79c94f4

External References:
https://lists.x.org/archives/xorg-announce/2016-October/002720.html
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7949

Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
meta/recipes-graphics/xorg-lib/libxrender/CVE-2016-7949.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-lib/libxrender_0.9.9.bb

diff --git a/meta/recipes-graphics/xorg-lib/libxrender/CVE-2016-7949.patch b/meta/recipes-graphics/xorg-lib/libxrender/CVE-2016-7949.patch
new file mode 100644 (file)
index 0000000..73315b1
--- /dev/null
@@ -0,0 +1,59 @@
+From 9362c7ddd1af3b168953d0737877bc52d79c94f4 Mon Sep 17 00:00:00 2001
+From: Tobias Stoeckmann <tobias@stoeckmann.org>
+Date: Sun, 25 Sep 2016 21:43:09 +0200
+Subject: Validate lengths while parsing server data.
+
+Individual lengths inside received server data can overflow
+the previously reserved memory.
+
+It is therefore important to validate every single length
+field to not overflow the previously agreed sum of all invidual
+length fields.
+
+v2: consume remaining bytes in the reply buffer on error.
+
+CVE: CVE-2016-7949
+Upstream-Status: Backport
+
+Signed-off-by: Tobias Stoeckmann <tobias@stoeckmann.org>
+Reviewed-by: Matthieu Herrb@laas.fr
+Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
+
+diff --git a/src/Xrender.c b/src/Xrender.c
+index 3102eb2..71cf3e6 100644
+--- a/src/Xrender.c
++++ b/src/Xrender.c
+@@ -533,12 +533,30 @@ XRenderQueryFormats (Display *dpy)
+       screen->fallback = _XRenderFindFormat (xri, xScreen->fallback);
+       screen->subpixel = SubPixelUnknown;
+       xDepth = (xPictDepth *) (xScreen + 1);
++      if (screen->ndepths > rep.numDepths) {
++          Xfree (xri);
++          Xfree (xData);
++          _XEatDataWords (dpy, rep.length);
++          UnlockDisplay (dpy);
++          SyncHandle ();
++          return 0;
++      }
++      rep.numDepths -= screen->ndepths;
+       for (nd = 0; nd < screen->ndepths; nd++)
+       {
+           depth->depth = xDepth->depth;
+           depth->nvisuals = xDepth->nPictVisuals;
+           depth->visuals = visual;
+           xVisual = (xPictVisual *) (xDepth + 1);
++          if (depth->nvisuals > rep.numVisuals) {
++              Xfree (xri);
++              Xfree (xData);
++              _XEatDataWords (dpy, rep.length);
++              UnlockDisplay (dpy);
++              SyncHandle ();
++              return 0;
++          }
++          rep.numVisuals -= depth->nvisuals;
+           for (nv = 0; nv < depth->nvisuals; nv++)
+           {
+               visual->visual = _XRenderFindVisual (dpy, xVisual->visual);
+-- 
+cgit v0.10.2
+
index 44cb2e0ebb1eac20d89fffdbf1dfac9de97f0ac4..eac367906c2e464b7cf0de3dfad9ac2e9cafcc09 100644 (file)
@@ -19,5 +19,8 @@ XORG_PN = "libXrender"
 
 BBCLASSEXTEND = "native nativesdk"
 
+SRC_URI += "file://CVE-2016-7949.patch \
+        "
+
 SRC_URI[md5sum] = "5db92962b124ca3a8147daae4adbd622"
 SRC_URI[sha256sum] = "fc2fe57980a14092426dffcd1f2d9de0987b9d40adea663bd70d6342c0e9be1a"