]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-config: Add shutdown desktop file for qemu images
authorRichard Purdie <richard@openedhand.com>
Tue, 22 Jan 2008 22:01:39 +0000 (22:01 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 22 Jan 2008 22:01:39 +0000 (22:01 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3573 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oh/qemu-config.bb
meta/packages/oh/qemu-config/qemuarm/shutdown.desktop [new file with mode: 0644]
meta/packages/oh/qemu-config/shutdown.desktop [new file with mode: 0644]
meta/packages/oh/qemu-config/shutdown.png [new file with mode: 0644]

index 299aea2a76734e522a12778e9782b3f49a141d43..d7c401eb2ef8c2330b8c09201031c49ff2e281a4 100644 (file)
@@ -1,11 +1,13 @@
 DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
 LICENSE = "GPL"
 RDEPENDS = "distcc task-poky-nfs-server fakeroot"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "file://distcc.sh \
            file://anjuta-remote-run \
-           file://exports"
+           file://exports \
+          file://shutdown.desktop \
+          file://shutdown.png"
 
 S = "${WORKDIR}"
 
@@ -20,4 +22,10 @@ do_install() {
     
     install -d ${D}${bindir}
     install -m 0755 anjuta-remote-run ${D}${bindir}/
+    
+    install -d ${D}${datadir}/applications
+    install -m 0644 shutdown.desktop ${D}${datadir}/applications/
+
+    install -d ${D}${datadir}/pixmaps
+    install -m 0644 shutdown.png ${D}${datadir}/pixmaps/
 }    
diff --git a/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop b/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop
new file mode 100644 (file)
index 0000000..2a42af5
--- /dev/null
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Shutdown
+Comment=Close down the machine safely
+Exec=reboot
+Icon=shutdown.png
+Terminal=false
+Categories=Utility;
+StartupNotify=true
\ No newline at end of file
diff --git a/meta/packages/oh/qemu-config/shutdown.desktop b/meta/packages/oh/qemu-config/shutdown.desktop
new file mode 100644 (file)
index 0000000..c1cb805
--- /dev/null
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Shutdown
+Comment=Close down the machine safely
+Exec=halt
+Icon=shutdown.png
+Terminal=false
+Categories=Utility;
+StartupNotify=true
\ No newline at end of file
diff --git a/meta/packages/oh/qemu-config/shutdown.png b/meta/packages/oh/qemu-config/shutdown.png
new file mode 100644 (file)
index 0000000..abf3f79
Binary files /dev/null and b/meta/packages/oh/qemu-config/shutdown.png differ