]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: Sync with OE to pull in glibc cvs workaround
authorRichard Purdie <richard@openedhand.com>
Thu, 26 Jan 2006 11:28:45 +0000 (11:28 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 26 Jan 2006 11:28:45 +0000 (11:28 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@238 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/glibc/glibc-cvs-2.3.5/arm-no-hwcap.patch [new file with mode: 0644]
openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb

diff --git a/openembedded/packages/glibc/glibc-cvs-2.3.5/arm-no-hwcap.patch b/openembedded/packages/glibc/glibc-cvs-2.3.5/arm-no-hwcap.patch
new file mode 100644 (file)
index 0000000..d3263a7
--- /dev/null
@@ -0,0 +1,11 @@
+--- libc/ports/sysdeps/unix/sysv/linux/arm/dl-procinfo.h.orig  2005-12-11 14:49:51 +0100
++++ libc/ports/sysdeps/unix/sysv/linux/arm/dl-procinfo.h       2005-12-11 14:51:28 +0100
+@@ -64,7 +64,7 @@
+   HWCAP_ARM_VFP       = 1 << 6,
+   HWCAP_ARM_EDSP      = 1 << 7,
+-  HWCAP_IMPORTANT = (HWCAP_ARM_HALF | HWCAP_ARM_FAST_MULT)
++  HWCAP_IMPORTANT = HWCAP_ARM_FAST_MULT
+ };
+ static inline int
index e7e5c3564bb7ec7940b9d9bd0a057c33c46e41a5..5ee5583fc84fa50bffd48c5dd0c31aa7be9650e5 100644 (file)
@@ -7,7 +7,7 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
 CVSDATE = "20050627"
-PR = "r0"
+PR = "r1"
 
 GLIBC_ADDONS ?= "ports,linuxthreads"
 GLIBC_EXTRA_OECONF ?= ""
@@ -37,8 +37,6 @@ INHIBIT_DEFAULT_DEPS = "1"
 
 #         file://noinfo.patch;patch=1
 #         file://ldconfig.patch;patch=1;pnum=0
-#         file://arm-no-hwcap.patch;patch=1;pnum=0 \
-#         file://arm-memcpy.patch;patch=1;pnum=0 \
 #         file://arm-machine-gmon.patch;patch=1;pnum=0 \
 #         \
 #         file://arm-ioperm.patch;patch=1;pnum=0 \
@@ -47,6 +45,7 @@ SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc \
           cvs://anoncvs@sources.redhat.com/cvs/glibc;module=ports \
           file://arm-audit.patch;patch=1 \
           file://arm-audit2.patch;patch=1 \
+          file://arm-no-hwcap.patch;patch=1 \
           file://arm-memcpy.patch;patch=1 \
           file://arm-longlong.patch;patch=1;pnum=0 \
           file://fhs-linux-paths.patch;patch=1 \
@@ -81,6 +80,14 @@ def get_glibc_fpu_setting(bb, d):
 do_munge() {
        # Integrate ports into tree
        mv ${WORKDIR}/ports ${S}
+
+       # http://www.handhelds.org/hypermail/oe/51/5135.html
+       # Some files were moved around between directories on
+       # 2005-12-21, which means that any attempt to check out
+       # from CVS using a datestamp older than that will be doomed.
+       #
+       # This is a workaround for that problem.
+       rm -rf ${S}/bits
 }
 
 addtask munge before do_patch after do_unpack