]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc-testsuite: SkipRecipe if libc is not glibc
authorNathan Rossi <nathan@nathanrossi.com>
Fri, 13 Sep 2019 07:49:10 +0000 (07:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Sep 2019 08:54:21 +0000 (09:54 +0100)
To prevent issues with parsing or dependencies, limit this recipe to use
only when the libc is glibc (and libc-locale is glibc-locale).

Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/glibc/glibc-testsuite_2.30.bb

index 64fa8d87df4c0dcd608d51029f5f32d68ffea267..657fd4dbc1b176e0bd41c150ab731957b2b34fb0 100644 (file)
@@ -8,6 +8,13 @@ PROVIDES = ""
 # setup depends
 INHIBIT_DEFAULT_DEPS = ""
 
+python () {
+    libc = d.getVar("PREFERRED_PROVIDER_virtual/libc")
+    libclocale = d.getVar("PREFERRED_PROVIDER_virtual/libc-locale")
+    if libc != "glibc" or libclocale != "glibc-locale":
+        raise bb.parse.SkipRecipe("glibc-testsuite requires that virtual/libc is glibc")
+}
+
 DEPENDS += "glibc-locale libgcc gcc-runtime"
 
 # remove the initial depends