]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xf86-dri-lite: Update git recipe for latest versions
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 5 Feb 2010 12:13:47 +0000 (12:13 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 5 Feb 2010 12:13:47 +0000 (12:13 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros1.patch [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb

diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros1.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros1.patch
new file mode 100644 (file)
index 0000000..94852f0
--- /dev/null
@@ -0,0 +1,22 @@
+We need to insert the sysroot path into compiler commandlines for this
+kind of variable use, otherwise we're looking into /usr/include/.
+
+RP - 26/11/09
+
+Index: git/xorg-server.m4
+===================================================================
+--- git.orig/xorg-server.m4    2010-02-05 10:00:55.000000000 +0000
++++ git/xorg-server.m4 2010-02-05 10:02:12.000000000 +0000
+@@ -28,10 +28,11 @@
+ # Checks for the $1 define in xorg-server.h (from the sdk).  If it
+ # is defined, then add $1 to $REQUIRED_MODULES.
++m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
+ AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
+       AC_REQUIRE([PKG_PROG_PKG_CONFIG])
+       SAVE_CFLAGS="$CFLAGS"
+-      CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
++      CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
+       AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "xorg-server.h"
+ #if !defined $1
index e039f0ad5d296957c65f0f1d21cc0990e2c08727..4789f28f5fca66458a9c36fb778258778175678c 100644 (file)
@@ -1,11 +1,13 @@
 require xserver-xf86-dri-lite.inc
 
 PE = "1"
-PR = "r11"
-PV = "1.6.0+git${SRCPV}"
+PR = "r0"
+PV = "1.7.99+git${SRCPV}"
 
 PROTO_DEPS += "xf86driproto dri2proto"
 
+DEPENDS += "font-util"
+
 RDEPENDS_${PN} += "xkeyboard-config"
 
 #           file://cache-xkbcomp-output-for-fast-start-up.patch;patch=1 \
@@ -15,10 +17,11 @@ RDEPENDS_${PN} += "xkeyboard-config"
 #           file://xserver-DRI2Swapbuffer.patch;patch=1"
 
 
-SRC_URI = "git://anongit.freedesktop.org/git/xorg/xserver;protocol=git;branch=server-1.6-branch \
+SRC_URI = "git://anongit.freedesktop.org/git/xorg/xserver;protocol=git;branch=master \
            file://nodolt.patch;patch=1 \
-           file://fix_macros.patch;patch=1 \
-           file://libdri-xinerama-symbol.patch;patch=1"
+           file://crosscompile.patch;patch=1 \
+           file://fix_macros1.patch;patch=1"
+#           file://libdri-xinerama-symbol.patch;patch=1"
 
 # Misc build failure for master HEAD
 SRC_URI += "file://fix_open_max_preprocessor_error.patch;patch=1"