]> code.ossystems Code Review - openembedded-core.git/commitdiff
sato-icon-theme: Make sure the native icon mapping script is found and used correctly
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 12 Aug 2010 13:29:12 +0000 (14:29 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 12 Aug 2010 13:41:30 +0000 (14:41 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/sato-icon-theme/sato-icon-theme.inc
meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch [new file with mode: 0644]
meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb

index ca99d7a59c0599e4ebcc9b7bedb90320469aec82..a1669c6f2e26857ba4bf1e81354406aedc81a41b 100644 (file)
@@ -14,6 +14,8 @@ FILES_${PN} += "${datadir}"
 
 PACKAGE_ARCH = "all"
 
+EXTRA_OECONF += "--with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
+
 pkg_postinst_${PN} () {
         if [ "x$D" != "x" ]; then
                 exit 1
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch b/meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch
new file mode 100644 (file)
index 0000000..cfa6a0d
--- /dev/null
@@ -0,0 +1,51 @@
+pkg-config will only search the target sysroot and we want the native script. This 
+patch adds an option to allow the path to the tool to be specified.
+
+RP - 12/8/10
+
+Index: sato-icon-theme-0.4.1/configure.ac
+===================================================================
+--- sato-icon-theme-0.4.1.orig/configure.ac    2010-08-12 12:23:25.000000000 +0100
++++ sato-icon-theme-0.4.1/configure.ac 2010-08-12 12:48:14.000000000 +0100
+@@ -11,20 +11,29 @@
+ UTILS_REQUIRED=0.8.2
+-AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
+-PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
+-                 have_utils=yes, have_utils=no)
+-if test "x$have_utils" = "xyes"; then
+-   UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
+-   ICONMAP="$UTILS_PATH/icon-name-mapping"
+-   AC_SUBST(ICONMAP)
+-   AC_MSG_RESULT([yes])
+-else
+-   AC_MSG_RESULT([no])
+-   AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
+-                 and install sato-icon-theme])
++PKG_PROG_PKG_CONFIG()
++
++AC_ARG_WITH(iconmap,
++            AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
++            ICONMAP=$withval, ICONMAP="")
++
++if test "x$ICONMAP" = "x"; then
++   AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
++   PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
++                    have_utils=yes, have_utils=no)
++   if test "x$have_utils" = "xyes"; then
++      UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
++      ICONMAP="$UTILS_PATH/icon-name-mapping"
++
++      AC_MSG_RESULT([yes])
++   else
++      AC_MSG_RESULT([no])
++      AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
++                    and install sato-icon-theme])
++   fi
+ fi
++AC_SUBST(ICONMAP)
+ AC_CONFIG_FILES([
+ Makefile
index 1dc8f9381ea07c2ed6815746aa3d7bab292216e3..aa976b1022f359f1ef423b4e903973665375fcec 100644 (file)
@@ -2,4 +2,5 @@ require sato-icon-theme.inc
 
 DEPENDS += "icon-naming-utils-native"
 
-SRC_URI = "http://pokylinux.org/releases/sato/${PN}-${PV}.tar.gz"
+SRC_URI = "http://pokylinux.org/releases/sato/${PN}-${PV}.tar.gz \
+           file://iconpath-option.patch"