]> code.ossystems Code Review - openembedded-core.git/commitdiff
ofono: Initial recipe for ofono
authorJoshua Lock <josh@linux.intel.com>
Thu, 3 Dec 2009 16:17:07 +0000 (16:17 +0000)
committerJoshua Lock <josh@linux.intel.com>
Fri, 18 Dec 2009 11:47:44 +0000 (11:47 +0000)
Based on the connman recipe, add ofono.inc for generic recipe components
and use it from ofono_git.bb and tracking a fixed git revision and
ofono_0.12.bb packaging the latest release.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/conf/distro/include/poky-fixed-revisions.inc
meta/conf/distro/include/poky-floating-revisions.inc
meta/packages/ofono/files/ofono [new file with mode: 0644]
meta/packages/ofono/ofono.inc [new file with mode: 0644]
meta/packages/ofono/ofono_0.12.bb [new file with mode: 0644]
meta/packages/ofono/ofono_git.bb [new file with mode: 0644]

index 7674db261a78cb12ff3affc7a5a03b7d04e94a47..233da98815f164a8ce835b85558ec1e44a60fda0 100644 (file)
@@ -196,6 +196,7 @@ SRCREV_pn-qemugl-nativesdk = "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
 SRCREV_pn-gobject-introspection = "efa7266bcf78478ce62e8dd778a4f0417bfd4d15"
 #c54f10f4caef35b42229c48951ee647ef05ab557"
 SRCREV_pn-gobject-introspection-native = "efa7266bcf78478ce62e8dd778a4f0417bfd4d15"
+SRCREV_pn-ofono = "14544d5996836f628613c2ce544380ee6fc8f514"
 
 SRCREVMOZILLAHEADLESS ?= "f4348fd85697"
 
index 99907c539c0ad33cc07ba3742450a10366daeb20..503726546554e325ca796a7a1ed2817aca831bfa 100644 (file)
@@ -57,6 +57,7 @@ SRCREV_pn-libmatchbox ?= "${AUTOREV}"
 SRCREV_pn-tasks ?= "${AUTOREV}"
 SRCREV_pn-libjana = "${AUTOREV}"
 SRCREV_pn-mutter = "${AUTOREV}"
+SRCREV_pn-ofono = "${AUTOREV}"
 
 SRCREV_pn-dri2proto = "${AUTOREV}"
 #PREFERRED_VERSION_dri2proto ?= "1.99.1+git${SRCREV}"
diff --git a/meta/packages/ofono/files/ofono b/meta/packages/ofono/files/ofono
new file mode 100644 (file)
index 0000000..6d46fb8
--- /dev/null
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/ofonod
+PIDFILE=/var/run/ofonod.pid
+DESC="Telephony daemon"
+
+if [ -f /etc/default/ofono] ; then
+       . /etc/default/ofono
+fi
+
+set -e
+
+do_start() {
+       $DAEMON
+}
+
+do_stop() {
+       start-stop-daemon --stop --name ofonod --quiet
+}
+
+case "$1" in
+  start)
+       echo "Starting $DESC"
+       do_start
+       ;;
+  stop)
+       echo "Stopping $DESC"
+       do_stop
+       ;;
+  restart|force-reload)
+       echo "Restarting $DESC"
+       do_stop
+       sleep 1
+       do_start
+       ;;
+  *)
+       echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+       exit 1
+       ;;
+esac
+
+exit 0
diff --git a/meta/packages/ofono/ofono.inc b/meta/packages/ofono/ofono.inc
new file mode 100644 (file)
index 0000000..312d5bc
--- /dev/null
@@ -0,0 +1,14 @@
+HOMEPAGE = "http://www.ofono.org"
+SUMMARY  = "open source telephony"
+LICENSE  = "GPL"
+
+inherit autotools_stage pkgconfig update-rc.d
+
+INITSCRIPT_NAME = "ofono"
+INITSCRIPT_PARAMS = "defaults 22"
+
+do_install_append() {
+  install -d ${D}${sysconfdir}/init.d/
+  install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
+}
+
diff --git a/meta/packages/ofono/ofono_0.12.bb b/meta/packages/ofono/ofono_0.12.bb
new file mode 100644 (file)
index 0000000..0bccbb2
--- /dev/null
@@ -0,0 +1,9 @@
+require ofono.inc
+
+PV      = "0.12"
+
+DEPENDS  = "dbus glib-2.0"
+
+SRC_URI  = "http://www.kernel.org/pub/linux/network/ofono/${P}.tar.bz2 \
+           file://ofono"
+
diff --git a/meta/packages/ofono/ofono_git.bb b/meta/packages/ofono/ofono_git.bb
new file mode 100644 (file)
index 0000000..db6476f
--- /dev/null
@@ -0,0 +1,14 @@
+require ofono.inc
+
+S       = "${WORKDIR}/git"
+PV      = "0.12-git${SRCPV}"
+
+DEPENDS  = "dbus"
+
+SRC_URI  = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
+           file://ofono"
+
+do_configure_prepend () {
+  ${S}/bootstrap
+}
+