]> code.ossystems Code Review - openembedded-core.git/commitdiff
librsvg: update the loader database when installing the svg loader
authorRoss Burton <ross@openedhand.com>
Tue, 19 Aug 2008 15:18:55 +0000 (15:18 +0000)
committerRoss Burton <ross@openedhand.com>
Tue, 19 Aug 2008 15:18:55 +0000 (15:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5071 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/librsvg/librsvg_2.18.2.bb

index fa02a25d57fdd396c9b2965c4802fc914a8422e1..c33dca155f6c987d2005959d5507b7f40417e863 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Library for rendering SVG files"
 SECTION = "x11/utils"
 DEPENDS = "gtk+ libcroco cairo libxml2 popt"
 LICENSE = "LGPL"
-PR = "r2"
+PR = "r3"
 
 EXTRA_OECONF = "--disable-mozilla-plugin --without-svgz --without-croco --disable-gnome-vfs"
 
@@ -24,3 +24,12 @@ FILES_librsvg-gtk-dbg += "${libdir}/gtk-2.0/.debug \
 do_stage() {
        autotools_stage_all
 }
+
+pkg_postinst_librsvg-gtk() {
+if [ "x$D" != "x" ]; then
+  exit 1
+fi
+
+test -x ${bindir}/gdk-pixbuf-query-loaders && { gdk-pixbuf-query-loaders > ${sysconfdir}/gtk-2.0/gdk-pixbuf.loaders ; }
+test -x ${bindir}/gtk-update-icon-cache && gtk-update-icon-cache  -q ${datadir}/icons/hicolor
+}