]> code.ossystems Code Review - openembedded-core.git/commitdiff
gamin: Add from OE.dev
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 4 Feb 2010 12:46:10 +0000 (12:46 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 4 Feb 2010 12:46:10 +0000 (12:46 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta-moblin/packages/gamin/gamin/no-abstract-sockets.patch [new file with mode: 0644]
meta-moblin/packages/gamin/gamin_0.1.10.bb [new file with mode: 0644]

diff --git a/meta-moblin/packages/gamin/gamin/no-abstract-sockets.patch b/meta-moblin/packages/gamin/gamin/no-abstract-sockets.patch
new file mode 100644 (file)
index 0000000..b8aacfb
--- /dev/null
@@ -0,0 +1,54 @@
+--- /tmp/configure.in  2007-04-30 13:08:49.000000000 +0200
++++ gamin-0.1.8/configure.in   2007-04-30 13:10:53.285251000 +0200
+@@ -354,51 +354,6 @@
+     AC_DEFINE(HAVE_CMSGCRED,1,[Have cmsgcred structure])
+ fi
+-#### Abstract sockets
+-
+-AC_MSG_CHECKING(abstract socket namespace)
+-AC_LANG_PUSH(C)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM(
+-[[
+-#include <sys/types.h>
+-#include <stdlib.h>
+-#include <string.h>
+-#include <stdio.h>
+-#include <sys/socket.h>
+-#include <sys/un.h>
+-#include <errno.h>
+-]],
+-[[
+-  int listen_fd;
+-  struct sockaddr_un addr;
+-  
+-  listen_fd = socket (PF_UNIX, SOCK_STREAM, 0);
+-  
+-  if (listen_fd < 0)
+-    {
+-      fprintf (stderr, "socket() failed: %s\n", strerror (errno));
+-      exit (1);
+-    }
+-
+-  memset (&addr, '\0', sizeof (addr));
+-  addr.sun_family = AF_UNIX;
+-  strcpy (addr.sun_path, "X/tmp/dbus-fake-socket-path-used-in-configure-test");
+-  addr.sun_path[0] = '\0'; /* this is what makes it abstract */
+-  
+-  if (bind (listen_fd, (struct sockaddr*) &addr, SUN_LEN (&addr)) < 0)
+-    {
+-       fprintf (stderr, "Abstract socket namespace bind() failed: %s\n", 
+-                strerror (errno));
+-       exit (1);
+-    }
+-  else 
+-    exit (0);
+-]])],
+-              [have_abstract_sockets=yes],
+-              [have_abstract_sockets=no])
+-AC_LANG_POP(C)
+-AC_MSG_RESULT($have_abstract_sockets)
+-
+ if test x$enable_abstract_sockets = xyes; then
+     if test x$have_abstract_sockets = xno; then
+       AC_MSG_ERROR([Abstract sockets explicitly required, and support not detected.])
diff --git a/meta-moblin/packages/gamin/gamin_0.1.10.bb b/meta-moblin/packages/gamin/gamin_0.1.10.bb
new file mode 100644 (file)
index 0000000..144bf7a
--- /dev/null
@@ -0,0 +1,9 @@
+DESCRIPTION = "Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.gnome.org/~veillard/gamin/sources/gamin-${PV}.tar.gz \
+           file://no-abstract-sockets.patch;patch=1"
+
+EXTRA_OECONF = " --without-python " 
+
+inherit autotools_stage pkgconfig