]> code.ossystems Code Review - openembedded-core.git/commitdiff
ovmf: Fix build failure for PARALLEL_MAKE with no space
authorJason Wessel <jason.wessel@windriver.com>
Tue, 5 Dec 2017 17:51:16 +0000 (09:51 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 6 Jan 2018 10:11:42 +0000 (10:11 +0000)
The ovmf package fails to build if you use a PARALLEL_MAKE flag
without a space in it.  If you put the following in local.conf for
example:

     PARALLEL_MAKE = "-j4"

The build will fail with as follows:

| build.exe: error: Option -n only allows one instance in command line!
| WARNING: /opt/build/ovmf/git-r0/temp/run.do_compile.26080:1 exit 2 from '/opt/build/ovmf/git-r0/git/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER}'
| ERROR: Function failed: do_compile (log file is located at /opt/build/ovmf/git-r0/temp/log.do_compile.26080)

The failure is because the build.sh expects a space.  The simple work
around is to fix the recipe to add some white space.  The build.sh
only cares that it gets at least one space between the arguments, the
extra space if someone uses "-j 4" does not cause problems.

Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
(cherry picked from commit cf7f4705e65a877cb4b3ac8872369c1b2e81a7be)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/ovmf/ovmf_git.bb

index a98826210e4ca5241f3a628f3a38c77c4ef92fc0..fa0d66291d1307c652d08464c2fab0388fb2434f 100644 (file)
@@ -151,7 +151,7 @@ do_compile_class-native() {
 
 do_compile_class-target() {
     export LFLAGS="${LDFLAGS}"
-    PARALLEL_JOBS="${@ '${PARALLEL_MAKE}'.replace('-j', '-n')}"
+    PARALLEL_JOBS="${@ '${PARALLEL_MAKE}'.replace('-j', '-n ')}"
     OVMF_ARCH="X64"
     if [ "${TARGET_ARCH}" != "x86_64" ] ; then
         OVMF_ARCH="IA32"