]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 02:05:01 +0000 (02:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:39 +0000 (13:17 +0000)
Fix out of tree builds by placing built objects in the correct
location.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.7.bb

index 9e22563d8bff3917b943c8ea88f1fb1757e23c00..3a4f5a891dc095b4bb00a8354dafc0c7ebc26c89 100644 (file)
@@ -19,7 +19,7 @@ do_configure_prepend () {
 
 do_compile_prepend () {
        find ./ -print | grep -v ./patches | xargs chmod u=rwX
-       ( cd ${S}/util; ${BUILD_CC} subst.c -o subst )
+       ( cd ${S}/util; ${BUILD_CC} subst.c -o ${B}/util/subst )
 }
 
 do_install () {