]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-state: move state files to localstatedir
authorJoshua Lock <josh@linux.intel.com>
Tue, 10 Jan 2012 16:32:08 +0000 (08:32 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Jan 2012 14:53:02 +0000 (14:53 +0000)
alsactl creates the state files in /var/lib/alsa by default so switch
alsa-state to use files in that location.

Further, update the alsa-state init script to have the location of the
state files sed'ed into the script at do_install time (so as to remove
hard coding of directory paths).

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-bsp/alsa-state/alsa-state.bb
meta/recipes-bsp/alsa-state/alsa-state/alsa-state

index ecfa97530fd2b8aa5601c490370e13e87c94bfb8..bc17b25b3ee095cc1d3772f55bd09885b65fb96f 100644 (file)
@@ -26,11 +26,13 @@ INITSCRIPT_NAME = "alsa-state"
 INITSCRIPT_PARAMS = "start 39 S . stop 31 0 6 ."
 
 do_install() {
+    sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${WORKDIR}/alsa-state
     install -d ${D}${sysconfdir}/init.d
     install -m 0755 ${WORKDIR}/alsa-state ${D}${sysconfdir}/init.d
 
+    install -d ${D}/${localstatedir}/lib/alsa
     install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir}
-    install -m 0644 ${WORKDIR}/*.state ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/*.state ${D}${localstatedir}/lib/alsa
 }
 
 PACKAGES += "alsa-states"
@@ -40,14 +42,14 @@ RRECOMMENDS_alsa-state = "alsa-states"
 FILES_${PN} = "${sysconfdir}/init.d ${sysconfdir}/asound.conf"
 CONFFILES_${PN} = "${sysconfdir}/asound.conf"
 
-FILES_alsa-states = "${sysconfdir}/*.state"
+FILES_alsa-states = "${localstatedir}/lib/alsa/*.state"
 
 pkg_postinst_${PN}() {
        if test -z "$D"
        then
                if test -x /usr/sbin/alsactl
                then
-                       /usr/sbin/alsactl -f ${sysconfdir}/asound.state restore
+                       /usr/sbin/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
                fi
                # INITSCRIPT_PARAMS changed, so remove the old and
                # install the new setting.
index 84cdf0375084d05c7627453e295ec60b48f2a9de..985079149724337e10a6472dfbfe4f2791bdd118 100755 (executable)
@@ -9,9 +9,9 @@
 
 asound_restore(){
        echo "ALSA: Restoring mixer settings..."
-       if test -x /usr/sbin/alsactl -a -e /etc/asound.state
+       if test -x /usr/sbin/alsactl -a -e #STATEDIR#/asound.state
        then
-               /usr/sbin/alsactl -f /etc/asound.state restore &
+               /usr/sbin/alsactl -f #STATEDIR#/asound.state restore &
        fi
 }
 
@@ -19,7 +19,7 @@ asound_store(){
        echo "ALSA: Storing mixer settings..."
        if test -x /usr/sbin/alsactl
        then
-               /usr/sbin/alsactl -f /etc/asound.state store
+               /usr/sbin/alsactl -f #STATEDIR#/asound.state store
        fi
 }