]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake-native: enabled zstd support
authorSamuli Piippo <samuli.piippo@gmail.com>
Tue, 25 May 2021 12:40:48 +0000 (15:40 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 May 2021 12:20:44 +0000 (13:20 +0100)
CMake depends on having all formats supported and build issues can
arise when zstd is not available:
https://gitlab.kitware.com/cmake/cmake/-/issues/21552

Quote from a CMake dev:
"As far as CMake's design is concerned, we have no optional formats.
All should be supported. That's why we bundle sufficiently new versions
of libarchive and libzstd. If a distro builds with an older libarchive
that doesn't have zstd support, then that is not a proper packaging of CMake."

Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake-native_3.20.2.bb

index d91e42ef9a1b6b87c3e376a629b1f15917352fac..335097d38720f2e4a89086f43373cd9c499590c7 100644 (file)
@@ -1,7 +1,7 @@
 require cmake.inc
 inherit native
 
-DEPENDS += "bzip2-replacement-native xz-native zlib-native curl-native ncurses-native"
+DEPENDS += "bzip2-replacement-native xz-native zlib-native curl-native ncurses-native zstd-native"
 
 SRC_URI += "file://OEToolchainConfig.cmake \
             file://environment.d-cmake.sh \